Showing results for 
Search instead for 
Did you mean: 

Matrox G450 with RH 6.2

Go to solution
Occasional Advisor

Matrox G450 with RH 6.2


who can help me to get a Matrox G450 working with RH 6.2? We are using the Kernel 2.2.14-5


- Michael
Honored Contributor

Re: Matrox G450 with RH 6.2


This page give you which version of X Server support G450 video card.
In short, only X Server 4.1.0 support G450.
My understanding is RH6.2 include X Server 3.3.6 which is not supporting G450.

masanari iida
Kodjo Agbenu
Honored Contributor

Re: Matrox G450 with RH 6.2

Hello Mr Reiss,

Just an additional information : it may be possible to have XFree86 4.1.0 work with RedHat 6.2, but it would probably not be so easy.

First, try to download and install XFree86 4.1.0 from RawHide at the following URL :

You need a high speed internet connection, as the total size to be dowloaded would probably exceed 100 MB.
Of course, you will have to follow the links to download the dependencies.

Second, try to update the libc of your RedHat 6.2 to the latest version :

Third, change the default login from graphic to console (in /etc/inittab, change the initdefault value from 5 to 3). Logout from graphic environment, then at the console prompt (as root), type init 3 to shutdown X11.

Fourth, uninstall all XFree86 3.3.6 component (I don't have the list, but you can obtain it by typing rpm -qa | grep ^X).

Fifth, install XFree86 4.1.0. Some components may require dependencies : you can avoid this by using the "--nodeps" option of rpm. But you must make sure that all required components are downloaded and installed.

Sixth, make the following symbolic links :

-> /etc/X11/X points to /usr/X11R6/bin/XFree86
-> /var/X11R6/bin/X points to /usr/X11R6/bin/XFree86

Seventh, configure XFree86 (try to download a sample config file from the internet, then change it. The driver name for Matrox adapters is "mga").

At the end, type X to check whether you get the graphical display or not. If it doesn't work, check the error messages in /var/log/XFree86.0.log.
If you get it, go back to console (CTRL-ALT-BACKSPACE), then try to obtain a graphical login (just type /etc/X11/prefdm).
If it works, then change your inittab to set the graphical login by default (initdefault 5).

An advise : to simplify these steps, it would be great if you had a RedHat 7.1 installed on another machine, because it ships with XFree86-4.0.3, which is more similar to XFree86-4.1.0 than XFree86-3.3.6.

Good luck.


P.S. don't forget to assign a rank to this answer (from 1 to 10).

Learn and explain...