Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Mouse goes haywire on changing terminals.

Mustafa Motiwala
Occasional Advisor

Mouse goes haywire on changing terminals.

Hello,
I have a generic ps/2 mouse, and everytime i switch between virtual consoles my mouse goes completely haywire, it starts sending select and clicks even if i just move it.
do i need to configure the mouse seprately for the console? or has my ps/2 port simply lost it. I know its not my mouse coz i have tried it with different and new ones.
Thanx.
3 REPLIES
Balaji N
Honored Contributor

Re: Mouse goes haywire on changing terminals.

hi
not sure if this is the problem. but is gpm running and please check if there are any tunable settings in /etc/gpm.conf.

regards
balaji
Its Always Important To Know, What People Think Of You. Then, Of Course, You Surprise Them By Giving More.
Mustafa Motiwala
Occasional Advisor

Re: Mouse goes haywire on changing terminals.

well, i checked and gmp is running, but in the etc folder, theres only one file gmp-root.conf and well, i checked it and i really dont see how to 'tune' it.
Kodjo Agbenu
Honored Contributor

Re: Mouse goes haywire on changing terminals.

Hello,

You may know that both "gpm" and X11 use the same device for sending data to the mouse (normally /dev/psaux).

It is generally recommended to avoid running both "gpm" and graphical interface at the same time.

However, there is a method to make "gpm" run together with the X11 device. To do so, make sure of the protocol being used by the X11 driver for accessing the mouse. In general, it is PS/2 but it can be another one. Check in /etc/X11/XF86Config[-4].

Type "ps -efl | grep gpm" to check the current input parameters.

Kill the gpm process and launch it again with the appropriate options :

/usr/sbin/gpm -t ps/2 -m /dev/psaux

To check how to make it definitive, post another message with the distribution you are using.

Good luck.

Kodjo
Learn and explain...