Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Mouse moves to corner uncontrolably

Nicholas Hartley
Occasional Visitor

Mouse moves to corner uncontrolably

I just recently installed Linux on an AMD 750 computer with Win98 as a second OS. I installed 98 first and then RH 7.1. The problem is that when I move the mouse around, arbitrarely it will bounce to either the top-right or lower-left corner. Sometimes it will act like I had pressed the right mouse button bringing up that menu. Does anyone have a fix or idea for me. I have installed RH three times from two different sets of CD's. Thanks.
2 REPLIES
Kodjo Agbenu
Honored Contributor

Re: Mouse moves to corner uncontrolably

Hello Nicholas,


The problem you are describing ressembles a XWindow problem.

Check the following 2 issues :

1. Is "gpm" started ? (ps -ef | grep gpm)

"gpm" is a daemon program that enable cut-n-paste with mouse in console mode.

"gpm" can be in conflict with X11, trying to access the mouse. Therefore, some distributions systematically stop gpm when entering in X11 runlevel (level 5 in RedHat).

Normally, to avoid this, "gpm" must be launched with option "-t ", where "protocol" stands for the protocol identifier used by X11 to access the mouse. Check in /etc/X11/XF86Config or /etc/X11/XF86Config-4, InputDevice section related to mouse config : possible protocols are PS/2, IMPS/2, etc...

On my linux box, I have a PS/2 mouse, then I launch "gpm" with options "-t ps/2".

You can also choose to deactivate "gpm" while entering X11 mode (runlevel 5). To do so, go to /etc/rc.d/rc5.d, then suppress symbolic links to ../init.d/gpm (S??gpm).



2. Does the X11 driver currently in use match your graphic adapter ? Sometimes, graphic cards are not correctly detected by Linux install programs. Using the wrong driver may result in unexpected behaviour.
Go to the RedHat website, then check their compatibility matrix to see whether your graphic card is actually supported or not. You can also check this on XFree86 website (http://www.xfree86.org).

To change your X11 settings, use Xconfigurator (WARNING : back-up your current XF86Config files in /etc/X11).


Last thing : you can check the X11 startup log in /var/log/XFree86.0.log. If you want us (the community) to give you more help, please post the following information :

-> /var/log/XFree86.0.log
-> /etc/X11/XF86Config
-> /etc/X11/XF86Config-4
-> result of cat /proc/pci


Good luck.


Kodjo
Learn and explain...
Ivan Donchev
Valued Contributor

Re: Mouse moves to corner uncontrolably

Hi,
This should be improperly set protocol to the mouse in the Pointer section of the XF86Config file.
What type of mouse do you use?
I think there was a XF86Setup or something like this in RH(xf86setup ?? small, caps, who can remember - I personally use Storm Linux), or the Xconfigurator... they could help you with the right choice of driver. For example I could never get the Genius NetScroll Mouse work as Genius NetScroll under Mandrake. Just try a few different settings.