General
cancel
Showing results for 
Search instead for 
Did you mean: 

Mozilla 1.7.13 problems with plugins

 
Highlighted

Mozilla 1.7.13 problems with plugins

Hello out there in the space.
We get "magic" issues with plugins loaded by MOZ_PLUGIN_PATH.
I set MOZ_PLUGIN_PATH for acroread, flash, java, PView(3dViewer) in different order or only part of them ( business requierment ). Mozilla write a file $HOME/.mozilla/pluginreg.dat which include the plugin order and description. Unfortunately the content of the file is depending from previours start of Mozilla and setting of MOZ_PLUGIN_PATH. The result is, that some plugins are missing, some get a wrong MIME type definition and a wrong order ( default plugin first )
The setting "application.use_ns_finder" has NO effect.

How to bring Mozilla to use dynamically ( following MOZ_PLUGIN_PATH )defined plugins????

Thanks in advance
Karsten
3 REPLIES 3
Highlighted

Re: Mozilla 1.7.13 problems with plugins

Any reason you are using mozilla instead of firefox?
Highlighted

Re: Mozilla 1.7.13 problems with plugins

Hey Dennis!

Thanks for reading this thread :-)

Well, I´m working for AIRBUS Germany. It´s a "conflict" by requierments of some big software supliers like PTC/Dassault Systems. This companies only support this very old Mozilla version for thier software ( Windchill / CATIA )
I know, firefox will solve a lot of issues but I have no chance to change the predefined Mozilla version.

For my point of view it´s a BUG that MOZ_PLUGIN_PATH don´t work propper. But who will/can change this??


regards
Karsten
Highlighted

Re: Mozilla 1.7.13 problems with plugins

For my point of view it´s a BUG that MOZ_PLUGIN_PATH don´t work proper.

All I know about MOZ_PLUGIN_PATH is that I had to set it when I added mozex and saw it in the Linux documentation.

I assume you know about the URL: about:plugins
I don't think I needed to set it for acroread since it was an application not a plugin.