General
cancel
Showing results for 
Search instead for 
Did you mean: 

My graphical Package Management doesn't work

D.A.O
Occasional Visitor

My graphical Package Management doesn't work

Hi...
I recently installed redhat advance server 3 update 3 on a HP Proliant ML350 everything was fine every hardware was detected and i could install anything using the Package Management software until i update the operating system using up2date... now i have new kernel and updated software.. but now i want to install new packages from CDs and i can't install anything ... it ask me for Installation CD 3 and i put that CD and it doesn't do anything...

Now I could realize that RedHat mount that CD but when the system try to read it, redhat umount the cd automaticaly, why?? i really really don't know!!!.. but if i want to read it from console everything looks fine..

Why is the reason that is happenning?? how could i fix that?? there is any chance to get some patch for that??

Please write me back..

Thanks!!!


How could i fix that??
3 REPLIES
Steven E. Protter
Exalted Contributor

Re: My graphical Package Management doesn't work

Shalom,

Get a newer update store the iso images in an accessible place

system-config-packages --isodir=/isodir

/isodir is where the isos sit or are mounted.

This should permit you to add software and provide dependencies.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Ragu_3
Trusted Contributor

Re: My graphical Package Management doesn't work

Please show here the version nos. of the package "rpm", before and after the package update using the "up2date" package.
Debian GNU/Linux for the Enterprise! Ask HP ...
D.A.O
Occasional Visitor

Re: My graphical Package Management doesn't work

Hi..
first of all.. I tried the first suggestion and it didn't work.. it doesn't do anything...

second... the package redhat-config-package is just the same version... it didn't update.. the version is redhat-config-packages-1.2.9.2-1

i was analizing the source code .. redhat-config-packages is programmed in python.. it seems to be right but the problem begins in the moment when the program umount the cdrom device and try to mount it again.. aparently the program find like the device is busy.. I suppose.. there is a function in one of the libreries who tries to mount the disk..

the directory is:
/usr/lib/python2.2/site-packages/rhpl

and the file is..
diskutil.py

the function is:
_diskutil.mount(fstype, device, location, readOnly)

this procedure fails at the moment when he tries to mount the device... why?? i have no idea... and why is the reason after the update.. much less noooo idea... interesting isn't it??

Anyway in that moment i tried to force it.. and tried to change the source code to:

cmd='mount -t iso9660 -o ro /dev/cdrom /mnt/cdrom'
os.system(cmd)
and putting unavailable the rest of the code and force him to run.. but the message that it trows to me was the device /mnt/cdrom cannot be mounted because is busy or is already mounted... why?? i don't know..

so after that i reinstall every package related with python and redhat-config-package .. you know just in case... i could realized that python was update.. i didn't mind so i put away the updated version and reinstalled the original version of python...

In spite of that.. it didn't work.. Unbeliveable...!!! what is the cause???

well.. if you guys have any idea that could help please let me know..

Thanks for all..

Dave