General
cancel
Showing results for 
Search instead for 
Did you mean: 

Need help upgrading RHEL 5.0/PSP 7.90 to RHEL 5.3/PSP 8.20

D S Boswell
Occasional Visitor

Need help upgrading RHEL 5.0/PSP 7.90 to RHEL 5.3/PSP 8.20

Since I couldn't find a specific catagory for this request I thought I'd start in general and see where that takes me...

We are currently running a number of DL360 systems running RHEL 5.0 w/PSP 7.90 and we want to upgrade to RHEL 5.3 w/PSP 8.20. We started by upgrading RHEL first and now we can't get any of the PSPs to work. Have tried upgrading to 8.20 directly (big mistake as there are 7 releases in between and only a jump of 3 is supported) and have also tried doing it is steps, starting at 8.00. Both failed! Is the fact that we upgraded the OS first the issue or is this supported? I was wondering if anyone else has done this and they might be able to provide guidance as the the correct steps.

Thanks,
Dave
5 REPLIES
Joseph L. Casale
Regular Advisor

Re: Need help upgrading RHEL 5.0/PSP 7.90 to RHEL 5.3/PSP 8.20

You will need to uninstall 7.90, then update RHEL. Problem is that 8.20 doesn't support the current kernel, just original 5.3 kernel AFAIK.
THAKUR
Frequent Advisor

Re: Need help upgrading RHEL 5.0/PSP 7.90 to RHEL 5.3/PSP 8.20

Hi Dave,
No need to unistall 7.90.
you can upgrade your OS to RHEL5.3 & then install SS8.20
SS8.20 supports RHEL5.3, so it should work fine.
D S Boswell
Occasional Visitor

Re: Need help upgrading RHEL 5.0/PSP 7.90 to RHEL 5.3/PSP 8.20

Thanks for the responses but if you bear with me a little longer I have some follow up:

1) We had already upgraded the OS to 5.3, rebooted, and 7.90 did seem to be running fine. However, since we wanted some of the newer drivers, we next tried to upgrade to 8.20, but as I mentioned previously, that didn't work. I found a reference from HP that stated upgrades to the current version are only tested for three versions back. While it might work if there is a bigger jump, there are no guarantees. The problems I have all seem to be related to the old hprsm/hpasm services, i.e. they won't shut down cleanly so it causes the install process to fail.

2) When you say to remove 7.90, is there an option to do this via the installer that I don't see? I did get a copy of a script produced by HP that goes and removes all packages, but it seems to have the same issue with hprsm. Is there a better (i.e. supported) way of doing this?

Thanks again,
Dave
THAKUR
Frequent Advisor

Re: Need help upgrading RHEL 5.0/PSP 7.90 to RHEL 5.3/PSP 8.20

1) As per you per first point that, if you are facing problem regarding stopping of hpasm & hprsm, then you can first uninstall those components & try installing PSP8.20.


2)There is no option for uninstalling through installer. Better way is to do manual unistallation. Use "rpm -qa|grep hp" to list all the hp related companents & then you can go ahead & uninstall all the components.

Its true that, upgrade scenario is tested only for three versions back only, but still there is no problem in upgrading as in your case. Only thing is to do force installation.

Thanks
Joseph L. Casale
Regular Advisor

Re: Need help upgrading RHEL 5.0/PSP 7.90 to RHEL 5.3/PSP 8.20

@Thakur,
So psp 8.20 installs *fully* with the current RHEL 5.3 kernel? My experience and from what I read in the release notes, there are some kernel dependent components that install fine with the release kernel but not the current kernel.