General
cancel
Showing results for 
Search instead for 
Did you mean: 

No depot software at location /var/spool/sw

SOLVED
Go to solution
johnsonjthomas
Frequent Advisor

No depot software at location /var/spool/sw

Hi,

I am encountering an error when trying to install a depot file using the command "swinstall run_as_superuser=true -s /caliper.depot \*" . The error is as follows

======= 02/22/10 14:02:52 IST BEGIN swinstall SESSION (non-interactive)(jobid=nitkhp01-0046)

* Session started for user "root@nitkhp01".

* Beginning Selection
* Target connection succeeded for "nitkhp01:/".
ERROR:There is currently no depot software on host "nitkhp01" at location "/var/spool/sw". Make sure that an absolute pathname is specified for location (beginning with "/").
* Source connection failed for "nitkhp01:/var/spool/sw".
WARNING: More information may be found in the daemon logfile on this target (default location is nitkhp01:/var/adm/sw/swagentd.log).
* Selection had errors.

======= 02/22/10 14:02:52 IST END swinstall SESSION (non-interactive)(jobid=nitkhp01-0046)

I checked and there is no directory called sw under /var/spool. Could anyone tell as to what is happening. Any help would be great!

Thanks
12 REPLIES
smatador
Honored Contributor

Re: No depot software at location /var/spool/sw

Hi,
Don't put the relative path but the absolute
swinstall run_as_superuser=true -s /caliper.depot \*

HTH
Dennis Handly
Acclaimed Contributor

Re: No depot software at location /var/spool/sw

The correct format for swinstall is:
# swinstall -s /caliper.depot \*

(You forgot the -x.)
johnsonjthomas
Frequent Advisor

Re: No depot software at location /var/spool/sw

Hi smatador

The path given is absolute and not relative. I copied the depot file to /var/spool/sw/ directory. I tried to install it using the command using the command "swinstall run_as_superuser=true -s /var/spool/sw/caliper* \*". I am now getting the error saying that I dont have permission to do so. It says that the administrator should provide us with the required permissions using the swreg or swacl. But I am already root user (uid =0) but still it gives the same error. Could you suggest me as to solve this problem

Thanks
johnsonpk
Honored Contributor
Solution

Re: No depot software at location /var/spool/sw

Hi Johnson,

is there any specific reason to run it as superuser? does it mandatory for caliper?

Did you tried running with out run_as_superuser option ?

from man page
"
SD's nonprivileged mode is intended only for managing
applications that are specially designed and packaged.
This mode cannot be used to manage the HP-UX operating
system or patches to it. For a full explanation of
nonprivileged SD, see the Software Distributor
Administration Guide, available at the
http://docs.hp.com web site."





Dennis Handly
Acclaimed Contributor

Re: No depot software at location /var/spool/sw

>johnsonpk: is there any specific reason to run it as superuser? does it mandatory for caliper?

It is required to be root to install this software and most others. Since johnson was root, that option is useless.

>Did you tried running without run_as_superuser option?

That would work better since he forgot the "-x" as I mentioned above.
johnsonjthomas
Frequent Advisor

Re: No depot software at location /var/spool/sw

Hi johnsonpk

I have given the option run_as_superuser=true option and still it is showing the same error.

When I dont give the run_as_superuser=true option (swinstall -s /var/spool/sw/caliper_5.1.0.depot \*) then it shows the following error

There is currently no depot software on host "nitkhp01" at location "/var/spool/sw/caliper_5.1.0.depot". Make sure that an absolute pathname is specified for location (beginning with "/").

I had copied caliper_5.1.0.depot into /var/spool/sw before executing the swinstall command

Thanks
johnsonjthomas
Frequent Advisor

Re: No depot software at location /var/spool/sw

Hi Dennis

What should I give with the -x option when I execute it with "-x".

The command would be

swinstall -x option=value -s /var/spool/sw/caliper_5.1.0.depot \*

What should the option,value pair be?
johnsonjthomas
Frequent Advisor

Re: No depot software at location /var/spool/sw

Hi,

As I mentioned in my initial post,I did not have a /var/spool/sw directory initially.I made a sw directory and copied caliper_5.1.0.depot into /var/spool/sw/. After doing this I have executed the commands and have got the errors as mentioned above. Does this have anything to do with the errors that I am encountering?

Thanks
Dennis Handly
Acclaimed Contributor

Re: No depot software at location /var/spool/sw

>The command would be:
swinstall -x option=value -s /var/spool/sw/caliper_5.1.0.depot \*
>What should the option, value pair be?

Since "-x run_as_superuser=true" is the default and has caused you no end of trouble, leave it out.

>I had copied caliper_5.1.0.depot into /var/spool/sw

There is no need to do that. You should remove it and use your original copy.
johnsonpk
Honored Contributor

Re: No depot software at location /var/spool/sw

check the depot

swlist @

and post the output

once verified run

swinstall -s
( with out \*) this will invoke TUI
Dennis Handly
Acclaimed Contributor

Re: No depot software at location /var/spool/sw

>johnsonpk: check the depot: swlist @

Don't fall into the SD trap of having N ways to do things. A more consistent option is:
swlist -s

>swinstall -s
>(without \*) this will invoke TUI

No need to use the TUI, \* should work.
johnsonjthomas
Frequent Advisor

Re: No depot software at location /var/spool/sw

Hi

The problem is solved. I restarted the swagentd daemon and everything started working. Thanks a lot Dennis,johnsonpk and smatador.