General
cancel
Showing results for 
Search instead for 
Did you mean: 

ORA-27044 - HP-UX Error: 27: File too large

Schwerdtfeger, Frank
Occasional Visitor

ORA-27044 - HP-UX Error: 27: File too large

Hi

I've installed ORACLE 8.1.7.4 on HP-UX 11.00 64 bit

Now I get
ORA-27044 and HP-UX Error: 27 File too large when I create a database file (Size 2GB)
What's wrong ?

ulimit is ok:
$ ulimit
unlimited


Regards
Frank

7 REPLIES
Stefan Farrelly
Honored Contributor

Re: ORA-27044 - HP-UX Error: 27: File too large


you havent got largefiles on. To check do;

fsadm eg /var

And it will say largefiles or nolargefiles. If you have OnlineJFS you can modify it without unmounting, or else umount then use fsadm to turn on largefiles (files >2Gb), the remount.
Im from Palmerston North, New Zealand, but somehow ended up in London...
S.K. Chan
Honored Contributor

Re: ORA-27044 - HP-UX Error: 27: File too large

Have you got largefiles enabled on your FS ? For instance say /opt (/dev/vg00/lvol6).
# fstyp -v /dev/vg00/rlvol6 | grep f_flag
If it's set to 16 largefiles is enabled and it it's set to 0 largefiles is disabled.
To convert a FS to largefiles (without OnlineJFS) you would have to umount the FS and run ..
# fsadm -o largefiles /dev/vg00/rlvol6
and then modify /etc/fstab accordingly to include the "largefiles" flag in the mount entry.
A. Clay Stephenson
Acclaimed Contributor

Re: ORA-27044 - HP-UX Error: 27: File too large

Almostt certainly you need to enable largefiles. You can unmount and mount -o largefiles or if your have onlineJFS enable largefiles 'on the fly' with fsadm. Man mount_vxfs and fsadm_vxfs for details.

It is also possible that quotas are in effect but I'm all but certain that nolargefiles mounting is your problem.
If it ain't broke, I can fix that.
Oleg Zieaev_1
Regular Advisor

Re: ORA-27044 - HP-UX Error: 27: File too large

Hello.

You need largefiles flag to be enabled for filesystem you use.
If you have OnlineJFS - use fsadm
to check :
fsadm -F vxfs /YOUR_MOUNT_POINT
to set :
fsadm -F vxfs -o largefiles /YOUR_MOUNT_POINT
(no umount necessary)
If you don't have it - use steps described above.

Hope this helps.
Oleg
Professionals will prevail ...
Ken Hubnik_2
Honored Contributor

Re: ORA-27044 - HP-UX Error: 27: File too large

You need to enable largefiles on the filesystem.
Alexsandro Vilarouca
Occasional Contributor

Re: ORA-27044 - HP-UX Error: 27: File too large

Hello Frank

The ORacle does not recommend that if it uses datafiles bigger that 2 GB
@lex
Oleg Zieaev_1
Regular Advisor

Re: ORA-27044 - HP-UX Error: 27: File too large

Depends on your storage capabilites. However, generally speaking, performance on raw devices is considered by most of DBAs I know as a way to go, not on flat files.

Hope this helps,
0leg
Professionals will prevail ...