General
cancel
Showing results for 
Search instead for 
Did you mean: 

Oct 18 16:00:00 pcidev vmunix: file: table is full

linuswan_1
Occasional Visitor

Oct 18 16:00:00 pcidev vmunix: file: table is full

In my L2000 Server,my oracle server instance crashed today.In syslog.log,system reported "vmunix: file: table is full".In alter file of oracle,it reported "Thu Oct 18 16:20:19 2001
Errors in file /oracle/local/oracle/8i/u01/app/oracle/product/8.1.5/rdbms/log/ora_1668_pci.trc:
ORA-00313: open failed for members of log group 3 of thread 1
ORA-00312: online log 3 thread 1: '/oracle/local/oracle/8i/u01/app/oracle/oradata/pci/redo03.log'
ORA-27041: unable to open file
HP-UX Error: 23: File table overflow
Additional information: 2
Thu Oct 18 16:20:19 2001
LGWR: terminating instance due to error 313
Instance terminated by LGWR, pid = 1668
"
How to avoid it?
8 REPLIES
Eugen Cocalea
Respected Contributor

Re: Oct 18 16:00:00 pcidev vmunix: file: table is full

Hi,

Increase the number of files that can be opened. Rebuild your kernel with the new parameters. Reboot.

E.
To Live Is To Learn
Rainer von Bongartz
Honored Contributor

Re: Oct 18 16:00:00 pcidev vmunix: file: table is full

you have to adjust the kernel parameter 'nfile'

This is a very common error occuring when running ORACLE and not having set up you kernel correctly.

check here for information on 'nfile'

http://docs.hp.com/hpux/onlinedocs/os/KCparam.Nfile.html

you can use sam to adjust you kernel

Regards
Rainer
He's a real UNIX Man, sitting in his UNIX LAN making all his UNIX plans for nobody ...
Santosh Nair_1
Honored Contributor

Re: Oct 18 16:00:00 pcidev vmunix: file: table is full

This just means that you've hit a limit on the number of files that they system can have open at any given time, i.e. nfile. Increase this kernel parameter value either through sam or command line, i.e. (either way will require a reboot):

kmtune -s nfile=
mk_kernel
kmupdate
shutdown -ry 300

-Santosh
Life is what's happening while you're busy making other plans
Michael Tully
Honored Contributor

Re: Oct 18 16:00:00 pcidev vmunix: file: table is full

Hi,

Your kernel parameter 'nfile' is full, and it
needs to be increased.

To increase it do this:

# cd /stand/build
# /usr/lbin/sysadm/system_prep -s system
# vi system (make your changes to 'nfile'
and save the file)
# mk_kernel -s system
# kmupdate

Reboot your system

HTH
-Michael
Anyone for a Mutiny ?
Herve BRANGIER
Respected Contributor

Re: Oct 18 16:00:00 pcidev vmunix: file: table is full

Hi

I think you need to tune your kernel (in your
case you have to modify nfile parameter).
Use Sam -> Kernel configuration -> configurable Parameters
and rebuild your kernel

But I think that you need to tune more parameters
on a standard HPUX11 installation than this one.

For example have a look to this thread :
http://forums.itrc.hp.com/cm/QuestionAnswer/1,11866,0xfaebc6af36b7d5118ff10090279cd0f9,00.html

You can find docs for tuning on docs.hp.com site. And on oracle docs also...

HTH

Herv?


James R. Ferguson
Acclaimed Contributor

Re: Oct 18 16:00:00 pcidev vmunix: file: table is full

Hi:

The previous replies have identified the kernel parameter that needs to be increased, provided some good documentation, and shown a couple of ways to affect the tuning.

If you wich to monitor the value of current value 'nfile' (and 'nproc'), its ceiling as set in the kernel, and the number of times the high-water mark has been exceeded, you can use 'sar' or 'glance':

# sar -v 5 10

...will take ten samples at 5-second intervals.

Toggling the [t]able view in 'glance' will also expose the values of critical tables.

Regards!

...JRF...
Andreas D. Skjervold
Honored Contributor

Re: Oct 18 16:00:00 pcidev vmunix: file: table is full

Hi
Consider increasing the maxuser setting instead, then you'll get a balanced increase in your different kernel settings.

nrpoc=((MAXUSERS*3)+64)
nfile=(15*NPROC+2048)

Andreas
Only by ignoring what everyone think is important, can you be aware of what everyone ignores!
Andreas D. Skjervold
Honored Contributor

Re: Oct 18 16:00:00 pcidev vmunix: file: table is full

forgot:
Starting off with the Tuned Parameter Set:
General OLTP/Database Server system
from Kernel Configuration | Actions |Aply tuned parameter sets menu,
before setting the Oracle specific parameters is also a way to avoid getting to many surprises on the way.

Andreas
Only by ignoring what everyone think is important, can you be aware of what everyone ignores!