General

Omiagemt stopped and unable to start and syslog shows authentication failed for scom service accoun

 
jagannaathan
Occasional Contributor

Omiagemt stopped and unable to start and syslog shows authentication failed for scom service accoun

omiserver: is running
omiagent: is stopped

In Hpunix 11.31 server, When I try to restart or start it not starting omiagent and in Syslog the service account used “scommon” and the syslog shows “authentication process failed for scommon”
Also checked the password for scommon service account is correct and able to do su

Requesting for troubleshooting to fix the same - Thanks in advance
4 REPLIES 4
support_s
System Recommended

Query: Omiagemt stopped and unable to start and syslog shows authentication failed for scom service accoun

Hewlett Packard Enterprise (HPE) recommends:

 

1. HPE eIUM Administrator's Guide - Release 10.5, 27th Edition

KishJ
HPE Pro

Re: Omiagemt stopped, unable to start and syslog shows authentication failed for scom service a/c

Good morning,

 

Please check the version of OMI is in use

/opt/omi/bin/omiserver -v

 

Depending on the version authentication could be NTLM or Kerberos

From what you shared, it appears that the authentication is not local. So, the main question do you want it to be local? If yes, then please check:

 

# /etc/nsswitch.conf 

 

The passwd entry must be set to "files" first

 

This will refer /etc/passwd and resolve your user-name and password as appropriate

 

If local file is not being used which means you may be using NTLM or Kerberos, please refer "Troubleshooting Authentication" at the respective links 

NTML - https://github.com/microsoft/omi/blob/master/Unix/doc/setup-ntlm-omi.md#troubleshooting-authentication

Kerberos - https://github.com/microsoft/omi/blob/master/Unix/doc/setup-kerberos-omi.md#troubleshooting-authentication

 

Please let us know how it goes. We will be happy to help if the issue persists.


I am a HPE Employee

Accept or Kudo

jagannaathan
Occasional Contributor

Re: Omiagemt stopped, unable to start and syslog shows authentication failed for scom service a/c

Thank you KishJ for the responce.

OMISERVER version is OMI-1.0.8-4

/etc/nsswitch.conf I could not see entry , any sample to add into it?

Also SCOM tools team said from thier end unable to login into SCOMMON account and hence sking to configure in server end.

But from server end scommon account is set and able to login with passord as well.

KishJ
HPE Pro

Re: Omiagemt stopped, unable to start and syslog shows authentication failed for scom service a/c

Hi,

 

Here is a sample of /etc/nsswitch.conf file:

 

passwd:       files
group:        files
hosts:        files dns
ipnodes:      files
services:     files
networks:     files
protocols:    files
rpc:          files
publickey:    files
netgroup:     files
automount:    files
aliases:      files

 

Considering the version, it is Kerberos authentication that is being used. You may check the link I shared before. 

Please let us know the status.


I am a HPE Employee

Accept or Kudo