General
cancel
Showing results for 
Search instead for 
Did you mean: 

Omniback error with large files on Linux

James Stenglein
Occasional Advisor

Omniback error with large files on Linux

Hello,

Here is my issue...

I have OB2 on a HPUX 11.0 server and have installed the agents on both RH 7.2 and SUSE 7.3 which are both 2.4.x kernels. The backups work fine on linux except for large files, over 4gb, which gives the error:

[Minor] From: VBDA@sta1lx04 "/u5_dev" Time: 06/20/02 10:53:40
[81:76] /u5_dev/hrwizt.dmp
Cannot stat: ([75] Value too large for defined data type) => not backed up.

When we backup the same file on a HPUX machine it backups up fine. Does anyone have an idea as to how to work around this? Suggestions? I cannot find a patch for this issue and it has to be backed up on linux as it is a dump server.


PS - I am a point assigner and proud of it :)

4 REPLIES
Bruno Cunha
Frequent Advisor

Re: Omniback error with large files on Linux

Hello, I don't work with Omniback, but with Veritas Netbackup and Netbackup doesn't suport/work with largefiles in Linux, maybe Omniback has the same problem, I don't know ...
Do it today, don't leave for tomorrow
Chris Mitchell
Occasional Contributor

Re: Omniback error with large files on Linux

I think Veritas DataCenter 4.5 will now support files on Linux larger that 2GB. . .

Veritas NetBackup:
This README describes fixes contained in Maintenance Pack NB_45_4_M for the VERITAS NetBackup (tm) UNIX Servers.

Description:
A new Linux client was added (Linux 2.4) and the code modified to support files that are larger than 2GB.

(NetBackup Clients: Linux2.2 )

http://seer.support.veritas.com/docs/254727.htm
Donuts.... Is there anything thy can't do?
Caesar_3
Esteemed Contributor

Re: Omniback error with large files on Linux

Hello!

You should check to upgrate the linux client
with the latest version.
I don't know which version you have but
was problems with suport large files in linux.

Caesar
Steven E. Protter
Exalted Contributor

Re: Omniback error with large files on Linux

Since Linux installs with largefiles enabled by default, I'd look at the HP-9000 cell manager.

Are largefiles enabled in the /var filesystem or wherever you have omniback storing files.

It copies files local to back them up, at least certain versions.

You are much better off with a more current verion of Omniback as Caesar says.

SEP

To enable largefiles on 11.00

fsadm if you have online jfs.

Otherwise:

umount /fsname

newfs -F vxfs -o largefiles /dev/vg00/rlvolname

modify /etc/fstab for the filesystem and change nolargefiles to largefiles

mount /fsname

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com