Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

Ora-00600

Magdalena Centeno
Occasional Visitor

Ora-00600

I'm receivin Ora-00600 error messages when trying to create some tables.

create table call(
*
ERROR at line 1:
ORA-00600: internal error code, arguments: [4097], [], [], [], [], [], [], []


Any ideas? How can I start looking for the problem? Which error log may help me?

Thanks
Steph
Only fail who don't keep trying
10 REPLIES
Marcel Boogert_1
Trusted Contributor

Re: Ora-00600

Hi there,

ORA-00600: internal error code, arguments: [string], [string], [string], [string], [string], [string], [string], [string]
Cause: This is the generic internal error number for Oracle program exceptions. It indicates that a process has encountered a low-level, unexpected condition. Causes of this message include:

timeouts
file corruption
failed data checks in memory
hardware, memory, or I/O errors
incorrectly restored files
The first argument is the internal message number. Other arguments are various numbers, names, and character strings. The numbers may change meanings between different versions of Oracle.

Action: Report this error to Oracle Support Services after gathering the following information:

events that led up to the error
the operations that were attempted that led to the error
the conditions of the operating system and databases at the time of the error
any unusual circumstances that occurred before receiving the ORA-00600 message
contents of any trace files generated by the error
the relevant portions of the Alter files
Note: The cause of this message may manifest itself as different errors at different times. Be aware of the history of errors that occurred before this internal error.

Regards, MB.
Marcel Boogert_1
Trusted Contributor

Re: Ora-00600

Hi there again,

Are you trying to create a table like in "create table call as(select"? If so, check your tablespace for enough free space.

Also check your alert file for errors

MB.
Rajesh SB
Esteemed Contributor

Re: Ora-00600

Hi,

Here is the latest thread on same error.

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=951147

Regards,
Rajesh
Patti Johnson
Respected Contributor

Re: Ora-00600

What version of Oracle are you running?

I did notice one bug that relates to corrupted rollback segments causing a similar error. Are you having other problems with this database?
Check the status of your rollback segments with.
select segment_name, status from dba_rollback_segs;
Also look in the alert.log for additional information.

Patti

Magdalena Centeno
Occasional Visitor

Re: Ora-00600

This is an old system using Oracle 7.3. I'm not having any problem in the system besides that, only that I cannot create those tables. I will check all you are saying...
Only fail who don't keep trying
Sandman!
Honored Contributor

Re: Ora-00600

Magdalena,

If you have Oracle Support [CSI number etc.], then your best bet is to open up a TAR with them.

regards!
Sandman!
Honored Contributor

Re: Ora-00600

Could you provide the SQL you are using to create the table(s)???

thanks
Sandman!
Honored Contributor

Re: Ora-00600

Did somebody drop and recreate the rollback segments after issuing a shutdown abort. Search for bug 427389 in Oracle's Metalink Site.

cheers!
Yogeeraj_1
Honored Contributor

Re: Ora-00600

hi,

can you try to check if your data files are ok?

one method will be to do a EXP and dump the whole database to a dump file.

if case of any error you will be immediately prompted.

if this works then you will have to verify if any trigger exists at the schema level which is affecting the creation of tables..

please check and let us know.
if still not ok, we will have to think something else.

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
dennebouy_1
Occasional Visitor

Re: Ora-00600

I had the same message when I tried to create a view in a non-existant schema
(oracle 9.2)

CREATE OR REPLACE VIEW non_existant.New_view_name as....

ORA-00600: internal error code, arguments: [rpidrv-3], [], [], [], [], [], [], []