Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

Ora 01650

Amit_38
Occasional Visitor

Ora 01650

Hi ,

When i am importing data from export i get an error Ora-01650 unable to assign initial extent

Why is this thrown up and what is the best solution ?

Thanx in adv
Amit.
4 REPLIES
Michael Schulte zur Sur
Honored Contributor

Re: Ora 01650

Hi,

it would be helpfull to know oracle version and patch level.
The error description at the bottom is from metalink and look a bit different than what you mentioned.

Can you check? Thanks,

Michael

ORA-01650: unable to extend rollback segment %s by %s in tablespace %s Cause: Failed to allocate extent for the rollback segment in tablespace. Action: Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace.
Victor Fridyev
Honored Contributor

Re: Ora 01650

Hi,

Using the option commit=y in the import command:
imp user/passwd file=exp_filename log=logname full=y commit=y ignore=y

should resolve the problem

Good luck

Victor
Entities are not to be multiplied beyond necessity - RTFM
Michael Schulte zur Sur
Honored Contributor

Re: Ora 01650

Hi,

one more thing. When you import and you can tell imp to put the whole table into one extent. That might not work.

Michael
Indira Aramandla
Honored Contributor

Re: Ora 01650

Hi Amit,

When you get the error "ORA-01650 unable to assign initial extent" while importing, that means the tablespace in which the table is being created does not have the number of contigues bytes to be allocated for the initial extent. Or if you exported with compress=Y then the import will try to put the complete data into one extent.

If you know the number of rows the table has and the size of the table then you can pre-create the table with the proper initial and next extents and then try to import the data with ignore=Y patameter.

Otherwise may be you require to increase (resize) the tablespace datafile or add a datafile to allocate more space to the tablespace.

Eg: alter tablespace add datafile 'path/datafile_name.dbf' size ?? M;

or

alter database datafile 'path/datafile_name.dbf' resize ?? M

Then try to import the table data.

I hope this helps

Indira A
Never give up, Keep Trying