Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Orackle Reports 6i

SOLVED
Go to solution

Orackle Reports 6i

I am trying to install oracle 6i on my HP-UX 11.11 PA box i get th following error while installing
Command: make -f ins_procbuilder.mk install
MOTIFLIBHOME=%motif_lib_dir% XLIBHOME=%x_lib_dir% 1>>
/oracle/home/ora92/orainst/install.log 2>>
/oracle/home/ora92/orainst/install.log

When i see th log file it says

cat /oracle/home/ora92/lib/sysliblist` -lm -lpthread -L/usr/lib/Motif2.1 -
L -R -lXm -lXt -lX11 -lm
/usr/ccs/bin/ld: /oracle/home/ora92/lib//libclntsh.sl:
Mismatched ABI. 64-bit PA
shared library found in 32-bit link.
*** Error exit code 1

Stop.

Please help

Regrads
Karthik
In Love with Life
9 REPLIES
Peter Godron
Honored Contributor

Re: Orackle Reports 6i

Hi,
normally the Mismatched ABI is down to inconsistent 32/64 bit compilation.
Can you ensure that all your code and libaries were compiled to the same bit level.

For the perl version of your problem:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=41898
Peter Godron
Honored Contributor

Re: Orackle Reports 6i

Karthik,
could also please read:
http://forums1.itrc.hp.com/service/forums/helptips.do?#28

Your record shows 0 points for 50 answers !
Did none of the answers help at all?!
Steven E. Protter
Exalted Contributor

Re: Orackle Reports 6i

Shalom,

I don't think Reports 6i is certified to work with an Oracle 9.2 back end database.

Its a 32 bit only release as well.

Please do something about your point assignment record.

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=140137

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Frank de Vries
Respected Contributor

Re: Orackle Reports 6i

You need to install a 64bit version of
Oracle 9i,
or fool the linker by soft-linking the
64bit libraries as 32bit libraries.
(64bit is backward compatible, but 32bit
is not upward compatible)
Look before you leap
TwoProc
Honored Contributor
Solution

Re: Orackle Reports 6i

Karthik,

You can probably get around this pretty easily by installing a copy of Oracle Datase 8.0.6 (or thereabouts) or mayble Oracle 8i into a new ORACLE_HOME, and then installing the forms 6.0.1 into that same ORACLE_HOME.

Don't create a database or anything, just install a goodly sum of the tools there (database, sqlnet, sqlplus, OCI layer (networking), etc). Then just run the installer from that directory and point it at that same ORACLE_HOME, then get the source from the CD that has the forms software.

That should fix it for you.
We are the people our parents warned us about --Jimmy Buffett
TwoProc
Honored Contributor

Re: Orackle Reports 6i

Good article you should read -
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1033211
We are the people our parents warned us about --Jimmy Buffett
HGN
Honored Contributor

Re: Orackle Reports 6i

Hi

I think with all the details provided by many of the experts should have helped resolving your issue, if you think this issue is resolved you can close this thread.

However you have no assigned points to any of the 55 responses received, hope you understand people are spending their valuable time helping out others and it is a nice way to show your gratitude by assigning points even a 1 point is better than not assigning any, hope you understand and appreciate the effort of others.

Rgds

HGN

Re: Orackle Reports 6i

Hi Experts,

How to softlink 64 bit library as 32 Bit???



Regards
Karthik
In Love with Life
Frank de Vries
Respected Contributor

Re: Orackle Reports 6i

In some situtations you can
link the named libraries to the
64path , so that it in effect
finds a 32bit library there.

so you need to use the libaries in oracle/product/9i/lib32
instead of oracle/product/9i/lib

You could do this by
mv lib _lib
ln -s oracle/product/9i/lib32
oracle/product/9i/lib

Or another approach is to ensure that the
oracle/product/9i/lib32 appears
first in the libray path
LD_LIBRARY_PATH=/usr/oracle/product/9.2.07/lib32

Same idea , but different method.
The idea is that the Oracle6i finds the libraries it needs during linking in its path.

Good luck
Look before you leap