Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle 10g HPUX

SOLVED
Go to solution
Shiju
Occasional Contributor

Oracle 10g HPUX

Hi
I installed Oracle 10g in HPUX version 11.11 successfully. But after installation I restarted the server and try to start listener, but it is not starting and I am getting a message as
No message file for product=network
Connection refused.

But if I try to start the listener after installation without restarting the server I can start it successfully.

any help will be highly appreciated.

Thanks in advance

Shiju.
5 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: Oracle 10g HPUX

Shalom Shiju,

The most common problems with this situation are environment and startup methodology.

Oracle must be started by the user you used to install oracle. Usually this is the oracle user.

Normally the startup script is begun by root as followes:

su - oracle -c "oracle startup command"

The next common problem is the oracle environment is not set up correctly. ORACLE_SID ORACLE_HOME are two important variables.

Another common problem is that oracles kernel guidelines for the OS are not followed. If nproc is not set high enough, oracle will be unable to start. There are a lot of possible causes.

Places to look:
/var/adm/syslog/syslog.log
Oracle alert log.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Yogeeraj_1
Honored Contributor

Re: Oracle 10g HPUX

hi Shiju,

Also, make sure you are runinng it under the appropriate Oracle User account too.

You may also wish to modify the .profile accordingly.
e.g.
ORACLE_SID=
ORACLE_BASE=
ORACLE_HOME=
CLASSPATH=

not to forget:
PATH=/opt/perl/bin:$PATH:/sbin:/usr/sbin:/etc:/usr/ccs/bin:/usr/bin:$ORAC
LE_HOME/bin:$JAVA_HOME/jre


hope this helps!
kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Shiju
Occasional Contributor

Re: Oracle 10g HPUX

Hi,

Thank you both for the help and support.

Shiju.
Sean Dale
Trusted Contributor

Re: Oracle 10g HPUX

It may not be necessary for this issue, but, I would strongly suggest you also set the NLS_LANG parameter as well.


You will need to set these

ORACLE_SID
ORACLE_HOME

also, add the oracle bin dir to your path
for example:
$ENV{PATH}="$ENV{PATH}:/opt/oracle9/bin";
Live life everyday
sasikala
Advisor

Re: Oracle 10g HPUX

Hi ,

Along with this please set SHLIB_PATH and LD_LIBRARY_PATH to access the shared library

Regards
Sasikala