Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle 10gR2 - problems with installation

SOLVED
Go to solution
Yuriy Vorobiev
Occasional Visitor

Oracle 10gR2 - problems with installation

Hello!

I have a problem - I can't install Oracle 10gR2 database to my system. Information about my system:

# uname -a
HP-UX hpux11i B.11.11 U 9000/800 1117424671 unlimited-user license

# model
9000/800/L3000-6x

# swlist -l bundle
# Initializing...
# Contacting target "hpux11i"...
#
# Target: hpux11i:/
#

B9007AAEVAL B.11.11.16.VAL1 HP C/aC++ Developer's Bundle
BUNDLE11i B.11.11.0306.1 Required Patch Bundle for HP-UX 11i, June 2003
Base-VXVM B.03.50.5 Base VERITAS Volume Manager Bundle 3.5 for HP-UX
CDE-English B.11.11 English CDE Environment
CMDVIEWSDM A.1.06.00 hp StorageWorks Command View SDM
FDDI-00 B.11.11.02 PCI FDDI;Supptd HW=A3739A/A3739B;SW=J3626AA
FEATURE11-11 B.11.11.0209.5 Feature Enablement Patches for HP-UX 11i, Sept 2002
FibrChanl-00 B.11.11.09 PCI/HSC FibreChannel;Supptd HW=A6684A,A6685A,A5158A,A6795A
GOLDAPPS11i B.11.11.0612.459 Applications Patches for HP-UX 11i v1, December 2006
GOLDBASE11i B.11.11.0612.459 Base Patches for HP-UX 11i v1, December 2006
GigEther-00 B.11.11.14 PCI/HSC GigEther;Supptd HW=A4926A/A4929A/A4924A/A4925A;SW=J1642AA
GigEther-01 B.11.11.07 PCI GigEther;Supptd HW=A6794A/A6825A/A6847A
HPUX11i-OE B.11.11.0212 HP-UX 11i Operating Environment Component
HPUXBase64 B.11.11 HP-UX 64-bit Base OS
HPUXBaseAux B.11.11.0212 HP-UX Base OS Auxiliary
HWEnable11i B.11.11.0612.458 Hardware Enablement Patches for HP-UX 11i v1, December 2006
IEther-00 B.11.11.03 PCI Ethernet;Supptd HW=A6974A
JAVAOOB 2.03.07 Java2 Out-of-box for HP-UX
Java15JDK 1.5.0.05.00 Java 1.5 JDK for HP-UX
Java15JDKadd 1.5.0.05.00 Java 1.5 JDK -AA addon for HP-UX
OnlineDiag B.11.11.09.11 HPUX 11.11 Support Tools Bundle, Dec 2002
RAID-00 B.11.11.01 PCI RAID; Supptd HW=A5856A
perl B.5.6.1.C Perl Programming Language

I had already updated my system using December 2006 paches. Also I'd intaller JDK 1.5 and tuned kernel parameters (as recommended by Oracle pre-installation tasks).

But when I trying to install Oracle DB by runInstaller-script, I receive several errors and warnings. To this post I included log-file (see attachment), where it possible to see, that there is error with OUI-11108 and some patches (PHSS_32508, PHSS_32509, PHSS_32510 and PHSS _32731). I can't install patches, because in my system there is HP aC++ A.03.73 compiler, but patches want to update HP aC++ A.03.60. I don't know, where can I get trial version A.03.60 of this compiler. Thus, I can't apply patches.

What to do with OUI-11108 - I don't know, really... More over, I don't know where to get this package...

So, I pressed "Install"-button and during installation I received several errors. such as:
"Error in invoking target 'ntcontab.o' of makefile '/va7410/lun1/oracle/product/10.2.0/db_1/network/lib/ins_net_clients' See log-file for details". Possible variant are [Help-button] [Retry-button] [Continue] [Ignore] [Cancel]. This happens when ProgressBar indicates 72%-73% (Linking 'Oracle Net Required Support Files 10.2.0.1').

After that, appears window with title "Oracle Universal Installer: Configuration Assistants."
There was a table with 3 columns "Tool", "Status" and "Type":
"Oracle Net Configuration Assistant"-"Succeeded"-"Recommended"
"Oracle Database Configuration Assistant"-"Failed(see details)"-"Recommended"
The 3rd assistant wasn't ran because the 2nd assistant fails with error "Error in Process /va7410/lun1/oracle/product/10.2.0/db_1/bin/orapwd".
This error appears when the assistent tried to create database and configure it.

Thus, I can't install database and I don't know how it is posiible to solve my errors.

If you have reach experience or know what should I do, please, help me. I really need your help!!!

Thanks in advance!

----------------
Best wishes,
Yuriy V. Vorobev
7 REPLIES
Robert-Jan Goossens_1
Honored Contributor
Solution

Re: Oracle 10gR2 - problems with installation

Peter Godron
Honored Contributor

Re: Oracle 10gR2 - problems with installation

Yuriy,
you can bypass the prereq check by using:
runInstaller -ignoreSysPrereqs

About your OUI_11108 please see:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=976140
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1092812

We need more info about your makefile problem, but I suspect it's the aCC compiler.
Please check your InstallAction and make.log files.

Please also read:
http://forums1.itrc.hp.com/service/forums/helptips.do?#33 on how to reward any useful answers given to your questions.

Re: Oracle 10gR2 - problems with installation

Hi Yuriy,

Just ignore the warning messages. These patches are used for compiling the Pro*C/C++ etc if need them. I had the same situation but the installation completed.

Good luck.
Xiaogang
Yuriy Vorobiev
Occasional Visitor

Re: Oracle 10gR2 - problems with installation

Thank you very much for your advices!!!

Nevertheless, not looking at your advices, the problem is still kept...

My steps:

1. As a usual, I tried to install the database ignoring all warnings and errors. The result was exactly the same - when started Oracle Database Configuration Assistant, it generates an error "Error in Process /va7410/lun1/oracle/product/10.2.0/db_1/bin/orapwd".

2. I tried to run Installer by the following command:
$ runInstaller -ignoreSysPrereqs
After installer starts, "Pre-Requisites" window appears again, and again I saw warnings and errors about not installed patches and OUI-11108. Of course, I ignorred this warnings and continued the installation. But when progress bar indicator showed 72%, the error window appears - "Error in invoking target...". I ignorred again this error again and continued with the installation. And again I met with Oracle Database Configuration Assistant, which failed...

3. Now I'm trying to find the necessary version of compiler, install it, and apply all necessary patches. Maybe it helps me (to say the true - I don't know :)

Maybe I should do something else?

P.S. Now I have installed compiler "HP aC++ C.03.70.VAL1" (Trial version). I suppose, I have to find and install such compiler, but with version "A.03.60"?

----------------
Best wishes,
Yuriy V. Vorobev
Yuriy Vorobiev
Occasional Visitor

Re: Oracle 10gR2 - problems with installation

Hello all!

I have some news :)

I just registered as HP DSPP-partner and then I downloaded HP aC++ and HP ANSI C compilers :) Then, I successfully installed patches PHSS_32508, PHSS_32509 and PHSS_32510.

Then I ran Oracle installer and it again said that some patches are missed. I looked through the log-list and found out that it is PHSS_32731. I tried to install it, but swinstall said that it is already installed in my system (it is very strange, because I can't find this patch by swlist...). I also tried to use "Reinstall" option, but it doesn't helped too...

So, I ignored this warning (about PHSS_32731) and pressed "Install" button. Taa-daa-m !!! The Oracle 10g was successfully installed !!!

When progress bar indicated 72%-73% (Linking "...") there wasn't any errors! Installation process was successfully ended :)

I'm very happy, because right now we can use
Oracle EM and iSQLPlus by web-interface. And my chief is happy too :)

So, I suppose, when Oracle Installer wants aC++ and ANSI C compilers - they must be installed in target system. If you don't know where to download this compilers, see http://www.hp.com/dspp

I'm ensured - this advice can help anybody, who has errors.

P.S. This topic will be closed in 2 days.
If you know, what should I do with PHSS_32731 and how can I install (or reinstall), please, drop a line.

--
Best wishes,
Yuriy V. Vorobev
Hein van den Heuvel
Honored Contributor

Re: Oracle 10gR2 - problems with installation

Yuriy,

I just wanted to thank you for providing full feedback on your problem resolution.

This will help others.

Regards,
Hein van den Heuvel
Yuriy Vorobiev
Occasional Visitor

Re: Oracle 10gR2 - problems with installation

-