General
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle 8.1.7 install on HP-UX 11.23 / PA RISC system

SOLVED
Go to solution
Joseph Luk
Occasional Advisor

Oracle 8.1.7 install on HP-UX 11.23 / PA RISC system

I had a new HP PA RISC system run on HP-UX 11.23, when I install Oracle 8.1.7 into this box, everything seems OK no error during installation, but when I use svrmgrl it had core dump with the following error message:-
/usr/lib/dld.sl: Bad magic number for shared library: /oracle/C11/817_64/lib64/libclntsh.sl.8.0

I try to un-install and re-install twice but same result. Can any one give me a hint to sort it out??

Thanks
Joseph
6 REPLIES
Ravi_8
Honored Contributor

Re: Oracle 8.1.7 install on HP-UX 11.23 / PA RISC system

Hi

Have you set the kernel parameters required to oracle 8.1.7 ( looks at the oracle docs for kernel values)
never give up
Biswajit Tripathy
Honored Contributor

Re: Oracle 8.1.7 install on HP-UX 11.23 / PA RISC system

Looks like your libclntsh.sl.8.0 has some problem.
Can you post output of the following:

$ file /oracle/C11/817_64/lib64/libclntsh.sl.8.0

- Biswajit
:-)
Yogeeraj_1
Honored Contributor
Solution

Re: Oracle 8.1.7 install on HP-UX 11.23 / PA RISC system

hi,

Setting the enviroment variable SHLIB_PATH to $ORACLE_HOME/lib instead of $ORACLE_HOME/lib64 should solve this problem.

There is an error in the installation guide.

Note that your enviroment variable LD_LIBRARY_PATH should include the $ORACLE_HOME/lib64 directory.

see metalink note: 136876.1 for more details


hope this helps!

regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Indira Aramandla
Honored Contributor

Re: Oracle 8.1.7 install on HP-UX 11.23 / PA RISC system

Hi Joseph,

HP-UX: 'Bad magic number for shared library' when running svrmgrl or sqlplus.

You have installed oracle 8i 64-bit on HP-UX 11.23, when trying to run run svrmgrl you get the following message:
Bad magic number for shared library: $ORACLE_HOME/lib64/libclntsh.sl.8.0

Your SHLIB_PATH enviroment variable included the wrong directory $ORACLE_HOME/lib64

As explained in the installation guide the enviroment variable LD_LIBRARY_PATH should include the $ORACLE_HOME/lib64 directory, but the SHLIB_PATH should include $ORACLE_HOME/lib.

Setting the enviroment variable SHLIB_PATH to $ORACLE_HOME/lib may solve this problem.

I hope this helps

Indira A
Never give up, Keep Trying
Joseph Luk
Occasional Advisor

Re: Oracle 8.1.7 install on HP-UX 11.23 / PA RISC system

Hi everyone,

THanks for your help , I did change the enviroment variable then the problem fixed.

Thanks again,
Joseph
Steven E. Protter
Exalted Contributor

Re: Oracle 8.1.7 install on HP-UX 11.23 / PA RISC system

You may run into other issues.

I do not believe that Oracle 8.1.7 which is obsolete is certified on 11 v 2 (11.23) PA-RISC or Itanium.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com