Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Showing results for 
Search instead for 
Did you mean: 

Oracle 8i on HP-UX 11i Create Database Error

Andrew Coulthard
Occasional Visitor

Oracle 8i on HP-UX 11i Create Database Error

I'm running Oracle 8i (64bit) on HP-UX 11i (64 bit).
I have installed patch PHSS_23441 but am still getting the ORA-03113 error when trying to use the "srvmgrl" to create the oracle database.

I have checked the HP-UX parameters and they all seem to agree with what Oracle (or this forum suggests)

Can any one tell me if there are other HP-UX patches I need to apply before going back to the Oracle Technical Support ?

Steve Slade
Frequent Advisor

Re: Oracle 8i on HP-UX 11i Create Database Error

I think that this might be an Oracle installation problem. I have seen this on Oracle 8.1.7 on HPUX 11.0. The problem occured when we installed a specific Oracle patchset.

In our case the problem occured whenever you attempted to open the database. If you tried to create a new database, the database is created and mounted, but is not opened. Instead you get the ora error message. (It does not tell you that it has created the instance and the mounted the db files.

In our case, we did not find the actual cause, as the patchset did work on another machine. We eventually cured the problem by re-installing - not a nice thing with the new 'improved?' Oracle Universal Installer. Before, this I would suggest trying to relink all the Oracle code again - there is a relinkall script, but I have forgotten where it is ORACLE_HOME/bin or maybe orainventory/bin?

Good luck.
If at first you do not succeed. Destroy all evidence that you even attempted.
Andrew Coulthard
Occasional Visitor

Re: Oracle 8i on HP-UX 11i Create Database Error

Thanks for the help.

There is a relink script in the \bin directory
I have executed this after any changes have been made without any apparent changes.

The best I've got from Oracle so far is that this is a HP-UX 11i problem solved by applying specifc patches, however the patch list they gave me was for HP-UX 11.00.

There are different patches for 11i.

Frequent Advisor

Re: Oracle 8i on HP-UX 11i Create Database Error

I got this error before when I had the environment variables not set correctly. Another thing may cause this error if the dbs directory does not exist($ORACLE_HOME/dbs).

David Reno

Re: Oracle 8i on HP-UX 11i Create Database Error

My experience in this area is that the kernel tunables are not set high enough. Try the following:

dnlc_hash_locks 512
eqmemsize 512
max_async_ports 1024
max_thread_proc 9100
maxdsiz 0X20000000
maxdsiz_64bit 0X40000000
maxfiles 512
maxfiles_lim 512
maxssiz 0X10000000
maxssiz_64bit 0X800000
maxswapchunks 10240
maxtsiz 0X4000000
maxtsiz_64bit 0X40000000
maxuprc 256
nfile 5000
nflocks 4500
ninode 5000
nproc 2512
nstrpty 60
semmni 2048
semmns 2048
shmmax 0X40000000
shmmni 800
Jon Finley
Honored Contributor

Re: Oracle 8i on HP-UX 11i Create Database Error

From ORacle's web site:
Problem Description

Creating a database using the Configuration Assistant fails with an ORA-03113
when trying to create the datafiles. The directories exist, the permissions
seem to be correct, and the environment is set correctly.

In addition, when you try to connect to Server Manager or SQL*Plus, it fails
immediately with an ORA-03113.

Solution Description

It seems that for some reason the "$ORACLE_HOME/dbs" directory is not there or
is a symbolic link. This is remedied by creating the "dbs" (using the Unix
command: mkdir dbs) directory under the $ORACLE_HOME directory even if it is
empty. This will allow Server Manager and SQL*Plus to connect; in addition, it
allows the Dbassist script to create the database.


There will not be any trace file nor any core dump. The reason is that if the
"dbs" directory is missing (thus your control file cannot be found by SQL*Plus
or Server Manager), Server Manager will not be able to get information about
your "core_dump_dest".

If you have an empty "dbs" directory, Server Manager will not return the
ORA-03113 error. Only when the directory is missing does Server Manager return
the error.
"Do or do not. There is no try!" - Yoda
Andrew Coulthard
Occasional Visitor

Re: Oracle 8i on HP-UX 11i Create Database Error

Thanks for all the replies so far.

I'm no nearer sorting out the problem.

I have checked the configuration parameters for HP-UX and all seems to agree with what I need.
The /dbs directory exists as expected.
The Oracle relink all executes successfully.
The install was done with the Oracle Universal installer.

I think I may be back to looking at patches from HP and/or Oracle

Any more ideas ?
Thwing Havens_1
Occasional Visitor

Re: Oracle 8i on HP-UX 11i Create Database Error

The error is due to you not setting the sticky bit on the oracle exe itself. Look at the post-installation instructions for tasks that need to be done by root. You need to do as root:

chmod 6751 $ORACLE_HOME/bin/oracle
Pornsak Lamaimuang
Occasional Visitor

Re: Oracle 8i on HP-UX 11i Create Database Error

I think you may receive same error when you run
SQL*Plus. Pls issue "ls $ORACLE_HOME/bin/oracle". If you see the size of file is 0 (zero).
Try increase kernel parameters named "maxdsiz" and "maxdsiz_64bit" to 1GB and reboot your machine. Then, reinstall oracle (not good thing) or relink only "oracle" binary.
The problem is there are not enough memory during the relink phase of the installation. You may see on "Out of memory" error.

Hope to solve your problem.

Pornsak Lamaimuang
Hello World!!!