Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle 9 64bit and DBD::Oracle

Kent Arnott
Occasional Advisor

Oracle 9 64bit and DBD::Oracle

I am attempting to compile DBD::Oracle 1.12 with Perl 5.8.0, to work with Oracle 9.2 64bit on HPUX 11.i.

I am using the HP ANSI C compiler.

Perl was configured with the following command,

./Configure -Duse64bitall -Aprepend:libswanted='cl pthread ' -Ubincompat5005

Perl compiles, tests, and installs fine.

When performing 'make test' with DBD::Oracle I receive the following linking errors,

PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/base......./usr/lib/pa20_64/dld.sl: Unable to find library 'libwtc9.sl'.
Failed to load Oracle extension and/or shared libraries:
install_driver(Oracle) failed: Can't load '/home/tec401/DBD-Oracle-1.12/blib/arch/auto/DBD/Oracle/Oracle.sl' for module DBD::Oracle: No such file or directory at /opt/perl5/lib/5.8.0/PA-RISC2.0-LP64/DynaLoader.pm line 229.
at (eval 1) line 3
Compilation failed in require at (eval 1) line 3.
Perhaps a required shared library or dll isn't installed where expected
at t/base.t line 19
The remaining tests will probably also fail with the same error.


I have also tried using '$perl Makefile.PL LINKTYPE=static' as well and receive a different error during linking.

cc +DD64 -L/usr/local/lib -L/lib/pa20_64 -Wl,-E -Wl,-B,deferred -o perl +O2 +Onolimit ./perlmain.o Oracle.o dbdimp.o oci7.o oci8.o blib/arch/auto/DBD/Oracle/Oracle.a /opt/perl5/lib/5.8.0/PA-RISC2.0-LP64/auto/DynaLoader/DynaLoader.a /opt/perl5/lib/5.8.0/PA-RISC2.0-LP64/CORE/libperl.a `cat blib/arch/auto/DBD/Oracle/extralibs.all` -lcl -lpthread -lnsl -lnm -ldl -ldld -lm -lc -lsec
ld: I/O error, file "sscoreed.o": No such file or directory


Perl -V is attached. Thank you for any help.
7 REPLIES
Kent Arnott
Occasional Advisor

Re: Oracle 9 64bit and DBD::Oracle

I found my problem. I feel so stupid.

I was executing 'make test' under an account that didn't have the SHLIB_PATH set.

I misinterpreted the README.hpux document that came with DBD::Oracle.

When it mentions that the ORACLE_HOME, ORACLE_SID, and ORACLE_USERID env vars are required for performing the make tests, I believed that was all that was required and got locked into a mindset.
稀里哗啦
Advisor

Re: Oracle 9 64bit and DBD::Oracle

I also need using DBD oracle too.
Can you kidly give me the below info?
Where are you got Perl5.8?
Do you compile the sourcecode youself?
which C compiler you used?

H.Merijn Brand (procura
Honored Contributor

Re: Oracle 9 64bit and DBD::Oracle

If you are going to use gcc, you can use the precompiled version from my ITRC website on https://www.beepz.com/personal/merijn/ or http://www.cmve.net/~merijn/
It is Oracle prepared, and has precompiled DBI with it, but it is 32bit only.

If you do not need 64bit Oracle, you also do not need a 64bit perl, and thus gain up to 20% performance.

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
稀里哗啦
Advisor

Re: Oracle 9 64bit and DBD::Oracle

I have dowload it.But when I using "perl" , it report "su: ./perl: Execute permission denied."
.
Can you help me?
I install it on a E25 machine and hpux 11.00/32bits.
Thanks
Jeff Schussele
Honored Contributor

Re: Oracle 9 64bit and DBD::Oracle

The file you are trying to execute is not allowed to do such.
Run chmod u+x ./perl
Then give it another shot.

HTH,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
稀里哗啦
Advisor

Re: Oracle 9 64bit and DBD::Oracle


Thanks for your help first.
I have done it, but the same error message report again.
Do you have some other advise?
H.Merijn Brand (procura
Honored Contributor

Re: Oracle 9 64bit and DBD::Oracle

Hmm, if you got my download, you have downloaded a compressed tar file, which is not executable.

# cd /opt
# mkdir perl
# cd perl
# bzip2 -d # ls

if the only folder that now shows up is perl, mv it up

# mv perl/* .
# rmdir perl

if you don't have bzip2, find it on the download page too

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn