Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle EXP-00002 error on HPUX10.20

Peter Spanhaak
Occasional Advisor

Oracle EXP-00002 error on HPUX10.20

Hi there,

I'm trying to do an Oracle 8.0.5 export, into a dumpfile created in a filesystem which support largefiles (newfs -o largefiles).

Somehow the export stoppes when the dumpfile size is 2.14xxx GB, which looks like a limitation on filesize.
Tried this a second time, but this gave me the same value for the dumpfilesize whe it stopped.
Looking in a subdir of the same filesystem showed me some oracle dbf files which are over 4 GB in size ???

Oracle itself gives the message
"systemerror 27 occured" when the export stops.
I tried to locate the messages file for HPUX , to find out the corresponding HPUX message,but couldn't find it yet.

Can anyone help me ?
7 REPLIES
Peter Spanhaak
Occasional Advisor

Re: Oracle EXP-00002 error on HPUX10.20

sorry forgot the mailadres:

Peter.spanhaak@atosorigin.com
Aashish Raj
Valued Contributor

Re: Oracle EXP-00002 error on HPUX10.20

Hi,

Although 805 supports datafiles of sizes > 2 GB, but it does not support export dumps over 2GB.
You can compress your dump files during export.

mkfifo /tmp/exp_pipe
compress > /expdata/export.dmp.Z \ < /tmp/exp_pipe &
sleep 60
exp user/pass file=/tmp/exp_pipe full=y compress=n log=/tmp/export.log

hope this helps
AR
Dave Chamberlin
Trusted Contributor

Re: Oracle EXP-00002 error on HPUX10.20

Aashish is coreect that Export does not support files > 2G. Aside from compressing your files, you may be able to use the split command to export into chunks, or use the filesize parameter with oracle 8i (see the bottom). Metalink had this to say:
Export to several files
~~~~~~~~~~~~~~~~~~~~~~~
(Note: Not all platforms support the split "-b" option used here)
% mknod /tmp/exp_pipe p # Make the pipe
% cd /fs_with_25gig_freespace # Make sure disk has space
% split -b2047m < /tmp/exp_pipe & # Split input to 2Gb chunks
% exp user/passwd file=/tmp/exp_pipe full=y # Export to the pipe

This will split the export into several files called 'xaa', 'xab', 'xac'
all of size 2047Mb. These can be fed back into import thus:

% mknod /tmp/imp_pipe p # Make the pipe
% cd /fs_with_25gig_freespace
% cat xaa xab xac > /tmp/imp_pipe & # Put files into the pipe
% imp user/passwd file=/tmp/imp_pipe # And import

The 'man' page for split shows options to generate more meaningful file names.

WARNING: Some versions of 'split' are very poor performance wise.

Export >2GB
~~~~~~~~~~~
Use the split example above
OR
Export to a NAMED PIPE and use unix 'cat' or 'dd' to copy from this to
a large file. The 'cat' or 'dd' command must support 64 bit write and
read offsets. Use the reverse for import.

Oracle8i introduced a new parameter (FILESIZE) which allows one to spread
exported data over multiple files. Details can be found in [NOTE:108639.1]
Jeanine Kone
Trusted Contributor

Re: Oracle EXP-00002 error on HPUX10.20

I am a bit confused by the prior comments. I have been creating large (> 2G) dump files since Oracle 7.3.4. Am I missing something here?

In any case, When we swicthed from our Alphas to the HPs we have now, I had a problem with the dump files. Some type of situtaion. Mine turned out to be a problem with the ulimit setting. Sorry I don't remember exactly what it was or what I had to change. This might give you a starting point anyway.



Brian Crabtree
Honored Contributor

Re: Oracle EXP-00002 error on HPUX10.20

Jeanine,

This is a problem only on UX systems. The NT exp command does not have a 2g upper limit.

Brian
Jeanine Kone
Trusted Contributor

Re: Oracle EXP-00002 error on HPUX10.20

I am sorry if this in inappropriate to ask here, but is this also a problem only with 8.0.5? I am using 8.0.6 on an HP_UX 11.0 machine and create 50 Gig dump files with no problem.
Brian Crabtree
Honored Contributor

Re: Oracle EXP-00002 error on HPUX10.20

Actually, I was mistaken. I just looked up some notes on Metalink regarding this (apologies for those without Metalink accounts)

http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_id=62407.1&p_database_id=NOT

It appears that 8.0.5 and 8.0.6 64bit can export over 2g with a patch, and 8.1.6 and 8.1.7 64bit can export over 2g standard. The filesystem in question does have to be configured for largefiles.

I apologize for giving out false information. The last time I did any checking on it, 8.0.6 was just coming out, and I was still under the impression that the 'exp' command was the limiting factor.

Brian