General
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle Universal Installer startup problem

David Nixon
Valued Contributor

Oracle Universal Installer startup problem

As a preliminary to installing the 9.2.0.5
patch set on my HP 11.0, Oracle 9i, database server, I have been trying to run the OUI version 2.3 that unpacks with the downloaded patches.
The "runInstaller" command fails to launch because it thinks the working directory is a CD mount point - even when run from another directory, or with the "Disk1" directory
renamed.
Anyone know of a workaround for this
behaviour?

DaveN.
5 REPLIES
Yogeeraj_1
Honored Contributor

Re: Oracle Universal Installer startup problem

hi,

try to Start the Oracle Universal Installer by specifying the full path:

e.g.

/ora-install/disk1/runInstaller

hope this helps!
regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
twang
Honored Contributor

Re: Oracle Universal Installer startup problem

Start the Oracle Universal Installer and Install the Oracle Software:
Change the current directory to /tmp and start the Installer. Example:
$ cd /tmp $ /cdrom/cdrom0/runInstaller

(I would suggest to stage the CD first.)
malay boy
Trusted Contributor

Re: Oracle Universal Installer startup problem

Well this is weird .Now i'm in the midst of installing the oracle 8.1.7.4 patch set and last month I do 9.2.0.4 patch , don't have this problem.

May be could you try this :
Go to $ORACLE_HOME/bin.

In there there are runInstaller.

cd $ORACLE_HOME/bin
next : ./runInstaller

remember to export the display first.

Good luck.

regards
mB
There are three person in my team-Me ,myself and I.
Shaikh Imran
Honored Contributor

Re: Oracle Universal Installer startup problem

Hi,
Also finally
Don't forget to mention the path of oracle home directory in the .profile file of oracle user.

Regards,

I'll sleep when i am dead.
David Nixon
Valued Contributor

Re: Oracle Universal Installer startup problem

Thanks for responsding so promptly, but
there doesn't seem to be a workaround, so
I will have to take this up with Metalink
or perhaps obtain patches on CD.

To further explain: the 9.2.0.5 patch set
downloaded from Metalink contains a 10G (2.3) version of OUI; which you must install under your ORACLE_HOME. You then use this
newly installed OUI to install the patches.

I have also tested the 10G OUI on the IAS
DVD, and this will launch OK from /tmp.
I haven't though, been able to point it at my downloaded patch directory.

This check of CWD was not present with the 9.2.0.4 patch set; which includes the 2.2 version of OUI.