Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle passwd

Oracle passwd

When I finished my BCV, I tried to start my database. But when i tried using the db by svrmgrl and by using connect internal it prompted a password. I usually don't see the message below when I use connect internal.

ORA-09925: Unable to create audit trail file
HP-UX Error: 2: No such file or directory
Additional information: 9925

What can I do to startup my database.
My database version is oracle 7.3.4.
and My OS version HP-UX 10.20.


Regards
maye
10 REPLIES
vinod_25
Valued Contributor

Re: Oracle passwd

hi maye

Ensure the Oracle audit directory has read and write permissions for the oracle user.

Check:
cd $ORACLE_HOME/rdbms
ls -ald audit

Permissions should be 775. (rwxrwxr-x)
Owner: oracle user

regards

Vinod

Re: Oracle passwd

I have already did that thing and still ends up with the same error. What could be the possible solution for this?


Regards
Maye
Sanjay Kumar Suri
Honored Contributor

Re: Oracle passwd

ORA-09925: Unable to create audit trail file
Cause: ORACLE was not able to create the file being used to hold audit trail records.
Action: Check the UNIX error number for a possible operating system error. If there is no error, contact ORACLE customer support.

Check for the value of AUDIT_FILE_DEST and the directory mentioned in the parameter exists.

sks
A rigid mind is very sure, but often wrong. A flexible mind is generally unsure, but often right.
Yogeeraj_1
Honored Contributor

Re: Oracle passwd

hi,

the audit directory should be in the oracle_home directory!

cd $ORACLE_HOME/rdbms/audit

you can verify this by querying it using svrmgrl:

SVRMGR> connect internal
Connected.
SVRMGR> show parameter audit
NAME TYPE VALUE
----------------------------------- ------- --------------
audit_file_dest string ?/rdbms/audit
audit_trail string NONE
transaction_auditing boolean TRUE
SVRMGR>

regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Yogeeraj_1
Honored Contributor

Re: Oracle passwd

hi again,

see also this metalink note. (attached)

regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Yogeeraj_1
Honored Contributor

Re: Oracle passwd

attached
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Eric Antunes
Honored Contributor

Re: Oracle passwd

Hi Maye,

What value do you have for audit parameters (select name, value
from v$parameter
where name like '%audit%';)?

Best Regards,

Eric Antunes
Each and every day is a good day to learn.
Patti Johnson
Respected Contributor

Re: Oracle passwd

Is the unix user that is attempting to start the database the same as the Oracle software owner?

Check the ownership and permissions on
$ORACLE_HOME/rdbms/audit
also ensure there is available free space in that directory.

Indira Aramandla
Honored Contributor

Re: Oracle passwd

Hi Maye,

ORA-09925: HP-UX Error: 2: No such file or directory Additional information: 9925.

The OS error indicates that either the directory is full or does not exists. So the file could not be created.


ORA-09925: Unable to create audit trail file
HP-UX Error: 2: No such file or directory
Additional information: 9925

This problem occurs when:
$ORACLE_HOME/rdbms/audit directory is full or directory doesn't exist

This error happens only on Unix systems. Oracle tries to create an audit file even if auditing is not enabled. By default this information is written to $ORACLE_HOME/rdbms/audit or to the directory specified by init.ora parameter audit_file_dest.

To fix this:

1. Ensure the directory $ORACLE_HOME/rdbms/audit or the directory specified by the init.ora parameter AUDIT_FILE_DEST exists, is writable by the oracle software owner and that the disk is not full. Make space available in $ORACLE_HOME/rdbms/audit or AUDIT_FILE_DEST by removing files that are not needed.

2. Check $ORACLE_HOME/bin/oracle has permission of 6755. If not, then correct the permissions by executing this from the $ORACLE_HOME/bin directory:
chmod 6755 oracle


Indira A
Never give up, Keep Trying
Ariel Cary
Frequent Advisor

Re: Oracle passwd

From the error stack you showed, it seems that the directory the audit_file_dest points does not exist.
As mentioned, the default values is $OH/rdbms/audit, but you may have this parameter set to another location. Make sure this dorectory exists and you have permission to write.

HTH,

ARC