Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle8i installation problem on HP-UX 11.0 in RAID env.

Sunit Shukla
Contributor

Oracle8i installation problem on HP-UX 11.0 in RAID env.

Hi Guys !

I am facing a unique problem in installing Oracle8i on HP-UX 11.0. HP server is connected to RAID system. When I am installing Oracle software and database directory on the same disk (system disks) it is OK but when I install Oracle on system disk and database directory is on RAID system it gives error, while creating databse it says -> ORA-03114 Not connected to Oracle. Also says ORA-27101 share memory realm does not exist.

In installation I opted all standard options. Also RAID is working and it connected. Can anyone suggest me what I am doing wrong and how I can correct this situation. Early response will be highly appreciated. Thanks.

Sunit Shukla
(212)702-1558
9 REPLIES
Volker Borowski
Honored Contributor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

Hi Sunit,

I am pretty confident, that this has nothing to do with your RAID system.

1) Check the permissions and the mountoptions of the Filesystems you use.
2) Check, if you can do
svrmgrl
connect internal
startup nomount
3) If any errors occur, hunt for the alertlog usually named alertSID.log i.e. by using
find / -name '*alert*' -print
may be you get additional usefull information.

Good hunting
Volker
Sunit Shukla
Contributor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

Thanks Volker, I will check as per your suggestion and post my findings in the forum. Is this related also with "share memory realm"'s existence.
Steven E. Protter
Exalted Contributor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

Shared memory realm issues are usually due to inadquate shared memory allocation in the kernel.

ipcs will display them.

There are plenty of old itrc posts that suggest how much memory to allocate.

My answer is subjective; more than you ever thought possible. Add even more if you have Software AG adabas, on the same system which gobbles up the same kind of resources.

This isn't a raid problem, of that I'm nearly certain.

As far as your errors go, been there done that, got the Oracle tee-shirt.

On a segway, please see my post on java issues and oracle.

http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0x1674ef70e827d711abdc0090277a778c,00.html

I cheated on the create_depot command, its the only one that starts with a c afer you unzip the file. Bad fingers. Type properly.

It goes ad infinitim on what to do to make sure Oracle is ready to run on an HP system.

Here is an ongoing thread with lots of good sql scripts being posted up.

http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0x4177ef70e827d711abdc0090277a778c,00.html

P
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Sunit Shukla
Contributor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

Hi Volker !

I checked the system as per your suggestion and here is the error message I got :
#./svrmgrl
Oracle Server Manager Release 3.1.7.0.0 Production

Message 4505 not found: no message file for product=SVRMGR, facility=MGR

error while trying to retrieve text for error ORA-12545

#SVRMGR>connect internal

message 701 not found; no message file for product=SVRMGR, facility=MGR

error while trying to retrieve text for error ORA-12545

#SVRMGR> startup nomount

MGR-00310: Message 310 not found; no message file for product= SVRMGR, facility=MGR


I also searched for alertSID.log files but did not find in the system.

Mr volker, I checked the the Kernel Shared memory parameters they are as it is :

shmmax= 67108864
shmmni= 200
shmseg = 120
shmem = 1



Can you idea why we can start the database and the error. Thanks.

Sunit
Sunit Shukla
Contributor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

Hi Steven !

I mentioned in my earlier response the setting of Kernel parameters for shared memory. Are they adequate.

Also in initSID.ora the SHARED_POOL_SIZE parametrs setting is default 32Mb. Kernel parametrs are :

shmmax= 67108864
shmmni= 200
shmseg= 120
shmem= 1

Will this information give you some clue or not. Your help will be appreciated. Thanks.

Sunit
Ian Lochray
Respected Contributor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

Sunit,
priot to starting svrmgrl, did you check that the environment variable ORACLE_HOME was set correctly. The errors you report are generated if ORACLE_HOME has an incorrect value. Try an "ls $ORACLE_HOME/bin/svrmgrl".
Volker Borowski
Honored Contributor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

Hi,

I suspect you try to run the svrmgrl as "root" and not your oracle-database-admin user.
Check /etc/passwd, ist could be "oracle" or likewise.
Switch to this user first (su - oracle).
Check then if the environment ist correct, as Ian suggested ($ORACLE_SID, $ORACLE_HOME)
They might be set apropriate through the installation.

67MB SHMMAX seems pretty low to me, but it might work if you have a very small database.
I'd recommend to increase it, depending on your physical memory available.
You might need to adjust oracle-profile params as well.

Good luck
Volker
Brian Crabtree
Honored Contributor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

Those settings are way to low. The following should be set:

maxdsiz 0XC0000000
maxdsiz_64bit 0X400000000
maxssiz 0X10000000
maxssiz_64bit 0X10000000
maxtsiz 0X40000000
maxtsiz_64bit 0X100000000
semmns 1024
shmmax 0X40000000

Also, you probably want to set the following:
dbc_max_pct 8
dbc_min_pct 3

Hope this helps,

Brian
BLADE_1
Frequent Advisor

Re: Oracle8i installation problem on HP-UX 11.0 in RAID env.

hi Sunit,

This could happen for number of reasons..

Just check out following ..

1. Check the entries in listener and tnsnames
2. Check the permissions on all the oracle files.
3. Check the environment variables like Oracle home and Oracle SID.
4. Try reducing the SGA size.
5.check the installation log and check for any errors during installation.

But I would place my bets on the variables not being set properly...

cheers
nainesh
fortune favours the brave