Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

POP3 with shadow password

BONNAFOUS Jean Marc
Trusted Contributor

POP3 with shadow password

I use a mail server on a trusted system (HP-UX 11.00, sendmail 8.9.3.1). I can read and send mail with elm, by when i want to download mail on a PC the passwords are not recognized. My POP3 server on HP-UX is a version of qpopper. (It's OK on a untrusted system).

Thanks for solution,

JMB
Si vous ne faites jamais de bétises, c'est que vous ne faites rien de difficile. Et ça c'est une grosse bétise.
3 REPLIES
Sridhar Bhaskarla
Honored Contributor

Re: POP3 with shadow password

Hi,

qpopper works well on solaris too that has by default the shadow password file. Did you try running the same qpopper on a non-trusted system and see if you didn't have a problem?. What does your syslog say?.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
someone_4
Honored Contributor

Re: POP3 with shadow password

If you dont have ldap.
You will need to add the mail users though sam. I would not suggest you do this with root. But make another user to the group mail. And set that password. Set up your outlook with stmp and pop server showing the ip of the mail server.and the username and password to reflect what you added in sam. This works for me just fine. Also make sure you have relay open.

Richard
Christopher Caldwell
Honored Contributor

Re: POP3 with shadow password

You've got to tell qpopper to use TCB (the trusted computing base).

To do this, use
./configure --enable-specialauth
instead in addition to/in lieu of the configure directive you used.

This switch is available for qpopper v3.0.2. Your mileage may vary for different versions. Read the INSTALL file - it has all the details.
If you need more info, post the version of qpopper you're using.