Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Showing results for 
Search instead for 
Did you mean: 

Password File on HP 11

Occasional Visitor

Password File on HP 11

I want to SHUTDOWN my database and I have lost the password for 'internal'.

I checked for the password file under ${ORACLE_HOME}/dbs/ .... I cudn't find any. Infact there are around 10 dbs running on the server but i cudn't find any password file for any of them. init.ora files were very much there.

I tried to run orapwd utility available under /{ORACLE_HOME}/bin and i gave file=${ORACLE_HOME}/dbs/orapw ... a file was generated. Yet I could not login as 'inetrnal'.

Can someone help me shutdown of my database ???

Thanks !!!
Christopher Caldwell
Honored Contributor

Re: Password File on HP 11

What version of Oracle? Our Oracle role account is authenticated by the OS. Thus we use something like
sqlplus /nolog
connect internal
Jared Westgate_1
Valued Contributor

Re: Password File on HP 11

Hello Sachin,

I think I have a real easy answer for you. Try to connect as internal using the SYS user's password (or anyone else that has been granted the DBA privelege). This should work. You should now be able to shutdown the database.

If that doesn't work, I guess I would start with the easy stuff. Who are you logged into as when you run svrmgrl? You need to run svrmgrl as the user that is in the oracle install group (oinstall or dba typically). In other words, It won't work if you run it as root.

The next thing to check is the init.ora file for your databases. Look for the REMOTE_LOGIN_PASSWORDFILE parameter. What is it set to? If it is none, you can't connect as internal. If it is exclusive, then each database has a password file. If it is shared, then all the databases share a password file. If it isn't defined, I THINK it defaults to none.

I assume you've already done a find for *pwd* and *orapw*?

Let us know if any of this works. Also, give us the version information if you can.

Best of luck,

Honored Contributor

Re: Password File on HP 11

Hello Sachin,

have to tried using the "old" passwords?

Sometimes (well, quite often) the are still working,
as dangerous as this is, it might be your friend now ;-)