General
cancel
Showing results for 
Search instead for 
Did you mean: 

Pavilion522n will not run linux

George Skokan_1
Occasional Visitor

Pavilion522n will not run linux

I have installed Red Hat 8.0 on the 522n, but the program will not start. It hangs during boot up after listing the items on the IDEs, eg Hard Drive & CD devices. Since Red Hat wouldn't start, I installed Mandrake 9.0 and it wouldn't start either. It hangs at the line apm: Bios version 2.2 Flags 0x0b. Both Red Hat and Mandrake installed without a hitch, but will not run. Anyone have any ideas while this model will not run linux? Both will run on a Pavilion 6638 that we have in another office.
4 REPLIES
Michael Armbrecht
Frequent Advisor

Re: Pavilion522n will not run linux

Your system hanging on "apm" indicates that there is a problem with the Advanced Power Management. Usually the problems arise due to a faulty implementation of APM in the BIOS. You have two options now:
1) If you can, disable APM support when installing Linux (as I don't know RedHat or Mandrake, I don't know if they give you an option for that).
1) Try to get a BIOS update. This might fix your issue.

Regards
Mick
Never be afraid to try something new. Remember, amateurs built the ark. Professionals built the Titanic.
Vincent Stedema
Esteemed Contributor

Re: Pavilion522n will not run linux

Hi,

Add the option "apm=off" to the boot command. This will disable apm.

Regards,

Vincent
George Skokan_1
Occasional Visitor

Re: Pavilion522n will not run linux

I was able to start both Red Hat and Mandrake with the statement "linux apm=off" I had to add the linux for it to find the module or something. BTW I had tried "linux noapic" and it didn't work. THX
Jerome Henry
Honored Contributor

Re: Pavilion522n will not run linux

You have to had Linux because it is the system you are booting !
2 solutions to ease your job :
edit your loader (/boot/grub/grub.conf if it is grub, /etc/lilo.conf if it is lilo, and add this argument at the end of the part concerning this boot (more explanation if required !).
/sbin/lilo to re-write to mbr if lilo (grub does it by itself).

do a chkconfig --level 2345 apm off
It'll stop apm launching at start (both solutions are OK) !
Good luck
J
You can lean only on what resists you...