cancel
Showing results for 
Search instead for 
Did you mean: 

Perl 5.8.3 download link

SOLVED
Go to solution
Srinikalyan
Regular Advisor

Perl 5.8.3 download link

Is there any where I get the software of Perl 5.8.3 for HP-UX so that I can download and install in one of the test server? Currently as part of the normal build we have only 5.8.8 which we dont need.

Thanks,
Srini
8 REPLIES
Pete Randall
Outstanding Contributor

Re: Perl 5.8.3 download link

James R. Ferguson
Acclaimed Contributor
Solution

Re: Perl 5.8.3 download link

Hi:

It's a shame not to take advanatage of 6-years of developement. Perl 5.8.3 dates to early 2004. If you insist, you can fetch it (and will need to compile it) from here:

http://search.cpan.org/~nwclark/perl-5.8.3/pod/perl583delta.pod

Regards!

...JRF...
Srinikalyan
Regular Advisor

Re: Perl 5.8.3 download link

I have got the Perl 5.8.3 version for HP-UX from HP. Can I just use the option 'allow_downdate' to downgrade the Perl to my required version from latest 5.8.8 without any problem.
swlist -x allow_downdate=true -s /tmp/perl5.8.3

Thanks,
Srini

Dennis Handly
Acclaimed Contributor

Re: Perl 5.8.3 download link

>Can I just use the option allow_downdate to downgrade the Perl to my required version from latest 5.8.8 without any problem?

It might be simpler to swremove the perl you have and then reinstall the older version.
Srinikalyan
Regular Advisor

Re: Perl 5.8.3 download link

Dennis,

Actually the installed perl version has lot of dependencies with other products or filesets.
* The fileset "Bastille.BASTILLE,l=/,r=B.3.0.31" requires the
selected fileset
"Perl5-64.PERL-RUN,l=/opt/perl_64,r=D.5.8.8.B" as a
corequisite.
* The fileset "Bastille.BASTILLE-AUX,l=/,r=B.3.0.31" requires
the selected fileset
"Perl5-64.PERL-RUN,l=/opt/perl_64,r=D.5.8.8.B" as a
corequisite.
* The fileset "SecurityTools.TOOLSFILESET,l=/,r=B.01.04.10"
requires the selected fileset
"Perl5-64.PERL-RUN,l=/opt/perl_64,r=D.5.8.8.B" as a
corequisite.

[.... Lot more.....]

Is it OK to forcefully remove the inetalled perl and install the lower version?

Thanks,
Srini
Dennis Handly
Acclaimed Contributor

Re: Perl 5.8.3 download link

>Is it OK to forcefully remove the installed perl and install the lower version?

Most likely not, unless 5.8.3 is installed elsewhere. Otherwise those tools may no longer work. You would probably have to remove those too.

Any reason you don't use 5.8.8 as JRF suggested?
James R. Ferguson
Acclaimed Contributor

Re: Perl 5.8.3 download link

Hi:

You shouldn't need to remove Perl. Installation of the different version will do that for you. I know this works when moving forward (up) in versions.

Regards!

...JRF...
Dennis Handly
Acclaimed Contributor

Re: Perl 5.8.3 download link

>JRF: You shouldn't need to remove Perl.

Yes but by using swremove it gave useful info about how "you can't get it up the steps". :-)