General
cancel
Showing results for 
Search instead for 
Did you mean: 

Powerpath upgrade 2.1.0 to 4.5.1 HPUX 11.11i

Powerpath upgrade 2.1.0 to 4.5.1 HPUX 11.11i

Tried upgrading to 4.5.1 as per EMC's recommendations i.e can do it directly from 2.1.0 to 4.5.1

However I made a mistake in that I installed (upgraded) to v4.5.1 using version for HPUX 11.00. System was 11.11i

Analysis phase signalled no error so I went ahead and installed. However during the reboot the system was not coming up - was caught in a loop sequence during initial botup sequence. Was not getting to the rc scripts.

Had to interrupt and boot from the previous version of the kernel vmunix.prev.

During the boot up sequence for Powerpath in the /sbin/rc2.d script it never started so no Powerpath running. Possibly due to v 11.00 installed

swlist shows 4.5.1 installed - no trace of 2.1.0. Still have the license info

So far I have renamed vmunix.prev to vmunix for future reboots.

My question now is how do I get Powerpath up and running. My steps would be to
==> remove the Powerpath software
==> reboot the server
==> Install correct version of 4.5.1 for 11.11i
==> reboot

You reckon this will do it ?
6 REPLIES
Sandeep_Chaudhary
Trusted Contributor

Re: Powerpath upgrade 2.1.0 to 4.5.1 HPUX 11.11i

I guess u need to remove the powerpath for 11.0 and upgrade powerpath for 11.11 version. After this if it doesnt work then go for furthet tracing
Jeeshan
Honored Contributor

Re: Powerpath upgrade 2.1.0 to 4.5.1 HPUX 11.11i

better to get help from EMC support or you can read the manual for installation of PowerPath software.
a warrior never quits
Steven E. Protter
Exalted Contributor

Re: Powerpath upgrade 2.1.0 to 4.5.1 HPUX 11.11i

Shalom,

Boot the system off the previous kernel

swremove the 11.00 version of powerpath and install the correct version.

You plan is essentially correct.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Powerpath upgrade 2.1.0 to 4.5.1 HPUX 11.11i

Just realised that I had installed the correct version of Powerpath. If I had just taken time to read the full description. Which says:-

HP_UX-B.11.00/11_32/64 so it's for 11.00 or 11.11i

However when I try and start Powerpath by issuing the /sbin/powermt config I get the following error:-

$ /sbin/powermt config
Unexpected error occured.


Any ideas ?
Kapil Jha
Honored Contributor

Re: Powerpath upgrade 2.1.0 to 4.5.1 HPUX 11.11i

You should always read manual first....on top of everything I feel powerpath creates some problems everytime u do smthing with it.(my personal exp).
Well did you rebooted ur system from the latest kernel as you said u booted your system with old kernel.
What is the error coming while booting.
BR,
Kapil+
I am in this small bowl, I wane see the real world......
Steve Post
Trusted Contributor

Re: Powerpath upgrade 2.1.0 to 4.5.1 HPUX 11.11i

I don't know what type of EMC array you have, but powerlink.emc.com has some tools that give you a walk through for certain tasks.

For me, I upgraded my powerpath using "Customer Clarion PG" program. This gave me a step by step procedure for the upgrade. A lot of the steps were like "if you use a left-handed spanner in AIX, run this step." But at least it gave me areas to watch.