Re: Problem in HP Proliant ML 150 running redhat linux 9.0

Saravana Kumar_2
New Member

Problem in HP Proliant ML 150 running redhat linux 9.0


Sorry for crossposting. I have posted this in shrike list too and my problem is such that i am seeking help from every where.

just a month ago bought a new Proliant server(Intel 7501, 512M RAM, 2 x ultra SCSI HDDs). I strauggled hard to install redhat linux 9.0 as the installation itself quit many times.

Let me explain the steps:
1. boot from cd with linux askmethod
2. give a ip for the system and ip of the NFS server.
3. partition / 3.5G (md1) /boot 100M(md0) and swap 1G.
4. select only x window, & kde package list.
and install.

The installation hang many times(repeating the steps again and again)--here, the same type of installation works ok in one of my assembled machines--after some 10 trials it installed. Nothing in logs when it hang. Then when syncing RAID it again hang.
Couldn't recover anything. Then again tried installing without RAID. This time it installed in the first attempt. I thought, so the prob was with the RAID. No, it wasn't.

it was running ok for a few days. One fine day i tried to copy a directory as a whole from one partition to another. It crashed again.With messages like:
Call Trace:.....
[some memlocation] scsi_iocompletion 0x185
ahd_run_qoutfifo 0xd0
rw_intr 0x75
scsi_bottom_half_handler 0x1f
bh_action 0x55
tasklet_hi_action 0x67
do_soft_irq 0xd9
do_irq 0xfb
default_idle 0x0
default_idle 0x0
call_do_irq 0x5
default_idle 0x0
default_idle 0x9
default_idle 0x29
cpu_idle 0x42
stext 0x0
CodeL Bad EIP value.
<0>kernel panic. Aiee, killing interrupt handler!
In interrupt handler - not syncing.

There are nothing in logs. I wrote them down in a paper and typing it here. Then i tried to copy big file same error. The system hangs with this error. Nothing then hard boot it.

i tried with the HP service person who came today with a new RAM(as i doubted the problem is with the RAM). same error. We checked the hdds. They are OK. I tried to reinstall the OS with the ZCR driver and installed health driver in the site. But in vain. Same error. I couldn't copy big files. Since the system is going to function as a server i has to be fixed as soon as possible(Another PIV system is now carrying the load without any problems). I recommended HP in my office and now getting screwed up for that.

Sorry again for cross posting. I send a mail to support also. But they simply mailed with call centre ph no. thro whom the engineer turned up.

Any helps appreciated, Also if anyone using redhat linux 9.0 in Proliant ML 150. please reply me so that i would know there is alteast some one with a environment similar to mine.

Steven E. Protter
Exalted Contributor

Re: Problem in HP Proliant ML 150 running redhat linux 9.0

A bad memory chip can cause this problem. If you have spares, you may have to swap them out. Sonds like an intermittant issue.

I've had the exact same problem with two other brands of servers.

Don't mean to contradict you but it was a bad RAM chip both times for me.

Steven E Protter
Owner of ISN Corporation
Saravana Kumar_2
New Member

Re: Problem in HP Proliant ML 150 running redhat linux 9.0

Thanks Steven.

I actutally reported this and tried with a new RAM also. Still the problem is there. Any ideas?