General
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

The following is the console log:

[root@nwhrprtl01 stage]# rpm -ivh hpasm-7.0.0-21.rhel21.i386.rpm
Preparing... ########################################### [100%]
1:hpasm ########################################### [100%]
Please read the Licence Agreement for this software at


/opt/compaq/hpasm/hpasm.license


By Not removing this package, you are accepting the terms
of the "License for HP Value Added Software".
==============================================================================
NOTE: In order to activate the software contained in this package, you must
type 'hpasm activate' as 'root' user.
You may subsequently reset your agent configuration by typing
'/etc/init.d/hpasm configure' or '/etc/init.d/hpasm reconfigure'.
==============================================================================
The hpasm RPM has installed successfully.

[root@nwhrprtl01 init.d]# hpasm activate
Turning on snmpd script at runlevel 2.
Turning on snmpd script at runlevel 3.
Turning on snmpd script at runlevel 4.
Turning on snmpd script at runlevel 5.
.
.
.
==============================================================================
NOTE: New snmpd.conf entries were added to the top of /etc/snmp/snmpd.conf
==============================================================================

==============================================================================
NOTE: New cma.conf entries were added to the top of /opt/compaq/cma.conf
==============================================================================
Starting HP Server Management Drivers and Agents, please wait ...
ls: /boot/vmlinuz.version.h: No such file or directory
ls: /boot/vmlinuz-2.4.9-e.35enterprise.version.h: No such file or directory

[root@nwhrprtl01 init.d]# hpasm start
The hp ProLiant Event Logging Driver is not available
for this Linux kernel: 2.4.9-e.35enterprise

Looking for sources to build 2.4.9-e.35enterprise

/lib/modules/2.4.9-e.35enterprise/build/include/linux/version.h does not match
the version of this kernel (2.4.9-e.35enterprise).

This is an indication that a patch has been loaded but not the sources
to match the running kernel. This driver requires the sources to all
kernel patches to be loaded in order to relink to the kernel symbols
ls: /boot/vmlinuz.version.h: No such file or directory
ls: /boot/vmlinuz-2.4.9-e.35enterprise.version.h: No such file or directory
11 REPLIES
Vijaya Kumar_3
Respected Contributor

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

It clearly says you dont have a kernel that is required:
vmlinuz-2.4.9-e.35enterprise.version

Please go through the documentation for getting this kernel from HP and install kernel rpms.

Thanks
VJ
Known is a drop, unknown is ocean - visit me at http://vijay.theunixplace.com

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

Thanks for the reply, but it's not clear to me. The contents of my /boot follow:

total 28811
2 drwxr-xr-x 4 root root 2048 Jan 23 17:36 .
4 drwxr-xr-x 23 root root 4096 Jun 3 04:02 ..
1 -rw-r--r-- 1 root root 512 Apr 5 2003 boot.6900
6 -rw-r--r-- 1 root root 5824 Jun 24 2001 boot.b
1 -rw-r--r-- 1 root root 612 Jun 24 2001 chain.b
1 drwxr-xr-x 2 root root 1024 Jan 23 17:32 grub
433 -rw-r--r-- 1 root root 439434 Jan 23 17:31 initrd-2.4.9-e.35enterprise.img
427 -rw-r--r-- 1 root root 433825 Jan 23 17:31 initrd-2.4.9-e.35.img
433 -rw-r--r-- 1 root root 440269 Jan 23 17:32 initrd-2.4.9-e.35smp.img
214 -rw-r--r-- 1 root root 217592 Apr 5 2003 initrd-2.4.9-e.3enterprise.img
211 -rw-r--r-- 1 root root 214184 Apr 5 2003 initrd-2.4.9-e.3.img
214 -rw-r--r-- 1 root root 217592 Apr 5 2003 initrd-2.4.9-e.3smp.img
0 lrwxrwxrwx 1 root root 14 Jan 23 17:32 kernel.h -> kernel.h-2.4.9
1 -rw-r--r-- 1 root root 484 Jan 23 17:32 kernel.h-2.4.9
12 drwx------ 2 root root 12288 Apr 5 2003 lost+found
94 -rw------- 1 root root 95232 Jan 23 17:33 map
24 -rw-r--r-- 1 root root 23108 Jun 24 2001 message
0 lrwxrwxrwx 1 root root 22 Jan 23 17:31 module-info -> module-info-2.4.9-e.35
15 -rw-r--r-- 1 root root 13599 May 3 2002 module-info-2.4.9-e.3
15 -rw-r--r-- 1 root root 13599 Dec 23 00:30 module-info-2.4.9-e.35
15 -rw-r--r-- 1 root root 13599 Dec 23 00:13 module-info-2.4.9-e.35enterprise
15 -rw-r--r-- 1 root root 13599 Dec 23 00:22 module-info-2.4.9-e.35smp
15 -rw-r--r-- 1 root root 13599 May 3 2002 module-info-2.4.9-e.3enterprise
15 -rw-r--r-- 1 root root 13599 May 3 2002 module-info-2.4.9-e.3smp
1 -rw-r--r-- 1 root root 640 Jun 24 2001 os2_d.b
0 lrwxrwxrwx 1 root root 31 Jan 23 17:36 System.map -> System.map-2.4.9-e.35enterprise
438 -rw-r--r-- 1 root root 444721 May 3 2002 System.map-2.4.9-e.3
442 -rw-r--r-- 1 root root 448948 Dec 23 00:30 System.map-2.4.9-e.35
463 -rw-r--r-- 1 root root 470520 Dec 23 00:13 System.map-2.4.9-e.35enterprise
463 -rw-r--r-- 1 root root 470397 Dec 23 00:22 System.map-2.4.9-e.35smp
459 -rw-r--r-- 1 root root 466214 May 3 2002 System.map-2.4.9-e.3enterprise
459 -rw-r--r-- 1 root root 466091 May 3 2002 System.map-2.4.9-e.3smp
2715 -rwxr-xr-x 1 root root 2767809 May 3 2002 vmlinux-2.4.9-e.3
2745 -rwxr-xr-x 1 root root 2797975 Dec 23 00:30 vmlinux-2.4.9-e.35
3080 -rwxr-xr-x 1 root root 3139745 Dec 23 00:13 vmlinux-2.4.9-e.35enterprise
3076 -rwxr-xr-x 1 root root 3135506 Dec 23 00:22 vmlinux-2.4.9-e.35smp
3046 -rwxr-xr-x 1 root root 3105369 May 3 2002 vmlinux-2.4.9-e.3enterprise
3038 -rwxr-xr-x 1 root root 3097034 May 3 2002 vmlinux-2.4.9-e.3smp
0 lrwxrwxrwx 1 root root 18 Jan 23 17:31 vmlinuz -> vmlinuz-2.4.9-e.35
980 -rw-r--r-- 1 root root 997736 May 3 2002 vmlinuz-2.4.9-e.3
990 -rw-r--r-- 1 root root 1007762 Dec 23 00:30 vmlinuz-2.4.9-e.35
1069 -rw-r--r-- 1 root root 1088300 Dec 23 00:13 vmlinuz-2.4.9-e.35enterprise
1066 -rw-r--r-- 1 root root 1085120 Dec 23 00:22 vmlinuz-2.4.9-e.35smp
1058 -rw-r--r-- 1 root root 1076755 May 3 2002 vmlinuz-2.4.9-e.3enterprise
1055 -rw-r--r-- 1 root root 1073371 May 3 2002 vmlinuz-2.4.9-e.3smp

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

I don't understand when you say I don't have this kernel. Can you explain further?
Thanks in advance. Your replies are very much appreciated.
Stuart Browne
Honored Contributor

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

What VJ said, is that you dont have the kernel SOURCE installed.

There is a package that is distributed with RHE called 'kernel-source-.rpm' of which has the files you're missing.

Once the 'kernel-source-2.4.9-e.35enterprise' package is installed, re-try /etc/init.d/hpasm start'.
One long-haired git at your service...
dirk dierickx
Honored Contributor

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

is anybody using these tools? they require a kernel module to compile and thus depend on a certain kernel version. every time the kernel gets an update you have to recompile your tools. at the same time you taint the kernel with forgein code.
i keep wondering if it is not possible to make these tools run as a normal app, outside the kernel.
right now i stay away from all softwares that require me add parts to the kernel that are not installed by default.
Stuart Browne
Honored Contributor

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

Dirk,

Yes, I use these tools on *EVERY* HP Proliant I have in the field, and those inhouse.

It doesn't taint the kernel as they are just loadable modules, and assuming you update all currently installed kernel RPM's (i.e. kernel-source + kernel), the start routine automatically re-compiles the modules on the fly.

I've never had these modules cause a machine to be unstable.
One long-haired git at your service...

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

Thanks guys for all your replies. I really do appreciate it. You guys are great. The fact is though that I do indeed have the kernel source installed. I have taken this issue up with HP support. I'll let you know the outcome. Thanks again.
Mark Grant
Honored Contributor

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

Brian,

"/boot/vmlinuz.version.h" looks very strange to me. Most installation routines of this typ e that I've seen look at kernel source version.h file to ermmm, check the version.

I have never seen a file like this one. One thing that might be fun to try though probably a waste of time would be to copy your /include/linux/version.h file to /boot/vmlinuz.version.h and see what happens.

Looks like an installation bug to me UNLESS the installation routine uses a path to your kernel sources that is set incorrectly.
Never preceed any demonstration with anything more predictive than "watch this"

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

Thanks. I think I know what the problem is.
I inherited these systems and the former Linux admin no longer works here. My theory is that the former admin installed a source driver and did the following:

cd /usr/src/linux-2.4.9-3.35
make mrproper
make oldconfig
make dep
.
.
I think this caused the kernel source to NOT match the currently running kernel.
I think the correct way is as follows:

cd /usr/src/linux-2.4.9-3.35
make KERNELRELEASE=`uname -r` oldconfig
make KERNELRELEASE=`uname -r` dep

This should force the kernel source to match the currently running kernel thus making the version.h file to have the correct information.

Thoughts??
Michael Garner_1
Honored Contributor

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

This issue will be resolved by a new health application that will replace the existing health driver in the 3Q04. The health application is currently in early test cycles.

The information about the kernel being tainted by the current health driver is correct. Because the driver is not open source, Red Hat considers the installation of the health application as a taint on the kernel. If you look at lsmod, it will show tainted with the current hpasm driver.

Regards,
Michael Garner
Linux PSP Developer

Re: Problem installing hpasm-7.0.0-21.rhel21.i386.rpm.

Previous Linux admin installed a source driver and configured the kernel source accoring to HP documentation for NIC driver bcm5700-2.2.23-1.src.rpm.
HP documentation for NIC driver bcm5700-2.2.30-1.src.rpm is not correct. It says to do the following:

cd /usr/src/linux-2.4.9-e.35
make mrproper
make oldconfig
make dep

which created /lib/modules/2.4.9-e.35enterprise/build/include/linux/version.h with incorrect entry (#define UTS_RELEASE "2.4.9-e.35custom").

To correct the problem, I reconfigured the kernel source correctly as follows:

make mrproper
make -e KERNELRELEASE=`uname -r` oldconfig
make -e KERNELRELEASE=`uname -r` dep

which created /lib/modules/2.4.9-e.35enterprise/build/include/linux/version.h
with the correct entry ((#define UTS_RELEASE "2.4.9-e.35enterprise").

Now hpasm-7.0.0-21.rhel21.i386.rpm installs and runs without errors.

Case closed. Thanks to all who replied.

-Brian Shepard