cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with idling linux

Alex Lavrov
Regular Advisor

Problems with idling linux

Hello,
I have redhat 7.3, but after couple of hours of idling it becomes very very very slow, takes ages to open telnet session or to work with already opened sessions, APMD is not running btw, any ideas?

thanx
8 REPLIES
Stuart Browne
Honored Contributor

Re: Problems with idling linux

What sort of hardware are you using, in particular, memory and processor.

Also, are you using a GUI interface (gnome/kde) or the text based?

What services are you running on the system?
One long-haired git at your service...
Balaji N
Honored Contributor

Re: Problems with idling linux

are u by any chance running fancy screen savers on the box?

can u do a ps -ef when the system becomes slow and paste it out over here.

and what are the applications this server is running

-balaji
Its Always Important To Know, What People Think Of You. Then, Of Course, You Surprise Them By Giving More.
Jerome Henry
Honored Contributor

Re: Problems with idling linux

And could you post here ps -aux result ?

J
You can lean only on what resists you...
Alex Lavrov
Regular Advisor

Re: Problems with idling linux

Hi, thanx for help,
I thought that the problem might be screensaver, so I already disabled them, and yes, I'm using KDE.

for ps -ef, I must wait for the next time machine will stuck, this morning I rebooted it.
Caesar_3
Esteemed Contributor

Re: Problems with idling linux

Hello!

Do you see that the problems only with work
via the network?
If so it could be problem of your network driver or the net card or even a cabel.

Do you have more than one machine with this configuration?

Caesar
Alex Lavrov
Regular Advisor

Re: Problems with idling linux

Hey,
after I removed screen saver it
s better now, this morning I looked in the "top" and saw that there is process logrotate that takes 98% of CPU!
I think logrotate and screensaver killed my linux ..
Balaji N
Honored Contributor

Re: Problems with idling linux

great. but dont disable logrotate. this basically moves ur log files around and maintains them that it doesnt grow out of size.

so u schedule it when there is minimal down time.
-balaji
Its Always Important To Know, What People Think Of You. Then, Of Course, You Surprise Them By Giving More.
Stuart Browne
Honored Contributor

Re: Problems with idling linux

This is why I asked what sort of hardware spec's you have.

As you are using it as a terminal, and thus not left on all of the time, the 'anacron' process of which gets executed when you start-up, will run. This will do daily/weekly/montly jobs as soon as it can, as close to the appointed time that it can.

This can mean that when you start up your machine, it could be doing any number of jobs because you're machien has been powered off for the weekend, or whatever.

I agree with Balji that you should NOT touch any of these scheduled jobs however. Just try to schedule them for when you aren't going to need to use your machine if it's having this much effect.

Also, if logrotate is taking more than a minute or two, it might be an idea to look at what it's getting stuck on rotating. The log files that get rotated weekly should only be a few hundred kb on a busy system. If it's taking a 'long time' to do it, there might be some sort of syslog problem causing garbage to be dumped to your log files. Also, if the 'compress' option is used in the logrotate config, it requires a fair bit of processing power to compress these files.

Just some things to think about.

NOTE: Easiest solution to anacron + scheduling jobs, leave your linux box on. Don't turn it off unless you REALLY have to.
One long-haired git at your service...