General
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with my ATI Radeon M7 in a Compaq Presario 2818AP

Vadim Zendejas
Occasional Visitor

Problems with my ATI Radeon M7 in a Compaq Presario 2818AP

I have a trouble with my video card when i want to install Linux Mandrake 9, so i want to know how to resolve the problem or if i need to install another things, im beginner in linux, so i want to know if you have instructions to configure the video card. Thanks
Vadim
2 REPLIES
Bruce Copeland
Trusted Contributor

Re: Problems with my ATI Radeon M7 in a Compaq Presario 2818AP

ATI Radeon video systems often do not configure properly during installation. You have two alternatives:

1) In the video configuration program (either during installation or subsequently), select the VESA driver (generic) as your video card and something like Generic Laptop Display Panel 1024x768 for your monitor. That should be enough to get X working.

2) Once you have Linux installed and running (including after step 1) you can then grab a working XF86Config file for an ATI Radeon M7 from another user with similar hardware. For that purpose you might try the links:

http://julien.lafaye.free.fr/debian/index.php
http://www.dcc.ufmg.br/~ghuiban/compaq_presario_2805/linux.html

You'll need to know where your XF86Config file goes on your Mandrake system (it's /etc/X11/XF86Config on Red Hat 8.0). You'll also need to know how to edit and move files around.

Bruce

Bruce Copeland
Trusted Contributor

Re: Problems with my ATI Radeon M7 in a Compaq Presario 2818AP

Oops, I also forgot to mention that you apparently need XFree86 4.2 or higher in order to use the ATI radeon driver. XFree86 4.1 should be sufficient for option 1) in my previous post, but you'll probably need to upgrade to at least 4.2 in order to make option 2) work.

Bruce