Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Proc Run Execute permission denied

guodong_1
Occasional Visitor

Proc Run Execute permission denied

Hi ,
I have write a proc program in HP-UNIX 11.0 64bits, Oracle 8.1.7.

All my compile is ok .
But when I run it . it give me a error likes "Execute permission denied" .
How can I do it . please give me some advice . Thank you very much .
guodong
5 REPLIES
Patrick Wallek
Honored Contributor

Re: Proc Run Execute permission denied

Do you change its permissions so it is executable?

# chmod 555 programname

If you are in the directory that the program is in, and that directory is NOT in your PATH, be sure to invoke it like:

# ./programname

guodong_1
Occasional Visitor

Re: Proc Run Execute permission denied

yes I have give the program the right to run by using chmod 777 . otherwise , I run it in the way like ./program
.
what can I do ?
guodong
Sajid_1
Honored Contributor

Re: Proc Run Execute permission denied

hello,

Do you have any Oracle error codes? This error comes because of various reasons:
a) You don't have permission to run functions or libraries which you call from the program.
b) any system commands you call from the program
c) any type of link error
d) patch issue
learn unix ..
Roger Baptiste
Honored Contributor

Re: Proc Run Execute permission denied

hi,

Seems that your program is accessing another executable or system routine/library and is not having permission to do it. If you have root access, can you try to run it as root. This will confirm the problem.

If you can put check points in your program, it can isolate the problem to its exact source.

HTH
raj
Take it easy.
Rick Beldin
Esteemed Contributor

Re: Proc Run Execute permission denied

I've seen this type of behavior if you build a program on a PA2.0 system and then take it to a system that only supports PA1.1. The binary appears correct, but since the architecture is incorrect, the loader won't run it.

Of course this makes little sense if this all in the same box.

Here's an example. simple was built on a 64-bit 11.00 system as a 32bit pa2.0 binary. It won't execute on a pa1.1 system:

$ file simple
simple: PA-RISC2.0 shared executable dynamically linked -not stripped

$ ll simple
-rwxrwxrwx 1 rbeldin users 20480 Aug 30 07:44 simple

$ ./simple
sh: ./simple: Execute permission denied.

Necessary questions: Why? What? How? When?