cancel
Showing results for 
Search instead for 
Did you mean: 

Progress9.1D patch to hpux 11i

SOLVED
Go to solution
nkkorhaz
Advisor

Progress9.1D patch to hpux 11i

i'd like patch my progress 9.1D and the /tmp/install/progress.patch/proinst this is write:

---CUT:
Cannot Read VersionInfo
Unresolved symbol: __|taticC
torTa /usr/|ib/dld.sl: Unresolved symbol: __ZStaticCtorTable_End (data) from /|sr/lib
/libC|uUnable to get version info from "/usr1/progress/9.1D" directory. |
/usr/|ib/dld.sl: Unresolved symbol: __StaticCtorTable_Start (data) from |usr/li
b/lib|sup.2
---ENDCUT.

why?

--
mezi@nkkorhaz.hu
5 REPLIES
Brad Kozak
Valued Contributor

Re: Progress9.1D patch to hpux 11i

Hello,

You must patch your HP-UX. Try the latest and greatest HP patch bundles.

Got this from the Progress
e-mail group (PEG):

At 12:55 1/10/2003, Tris wrote:
>Downloaded the 03 patch.
>Followed instructions and I get the following screen of gibberish when I try
>to run the patch install:
>
> | Cannot Read VersionInfonresolved symbol:
>__|taticCto
>rTable_+---------------------------------------------------------------+
>/usr/li|/dld.sl: Unresolved symbol: __ZStaticCtorTable_End (data)
>from|/usr/lib
>/libCsu|Unable to get version info from "/opt/progress/v91" directory. |
>/usr/li|/dld.sl: Unresolved symbol: __StaticCtorTable_Start (data) fro|
>/usr/li
>b/libCs|p.2 [Enter=OK] |
>/usr/li+---------------------------------------------------------------+m
>/usr/l
>ib/libCsup.2
>
>
>HP UX 11 (32 bit)
>Progress v9.1D
>
>What the heck's goin' on? The new-fangled eSupport knowledgebase had no
>answers for me.

Same thing happened to us. install.log has messages about dlls.

Tech support says that the HP-UX needs patching.


HTH,

bk
nkkorhaz
Advisor

Re: Progress9.1D patch to hpux 11i

which patch? :(
i'm searching for, but not found...

--
mezi@nkkorhaz.hu
S.K. Chan
Honored Contributor
Solution

Re: Progress9.1D patch to hpux 11i

I think the patch you need is ..
PHSS_26946 s700_800 11.11 HP aC++ -AA runtime libraries (aCC A.03.37)
That should get all your libraries updated. Reboot is not required and there are no other patch dependencies.
http://www1.itrc.hp.com/service/patch/patchDetail.do?patchid=PHSS_26946&context=hpux:800:11:11
nkkorhaz
Advisor

Re: Progress9.1D patch to hpux 11i

fine!

THANX!
Brad Kozak
Valued Contributor

Re: Progress9.1D patch to hpux 11i

An excerpt from Progress' support site..



Progress Solution ID: P26387

Title: "Cannot install Service Pack on HP-UX 11 - __ZstaticCtorTable errors"

Known to occur in:
??? Progress 9.1D
??? HP-UX 11


Symptom(s):
??? Getting following OS errors when install Service Pack

/usr/lib/dld.sl: Unresolved symbol: __StaticCtorTable_End (data) from /usr/lib/libCsup.2
/usr/lib/dld.sl: Unresolved symbol: __ZStaticCtorTable_End (data) from /usr/lib/libCsup.2
/usr/lib/dld.sl: Unresolved symbol: __StaticCtorTable_Start (data) from /usr/lib/libCsup.2

??? mfLoadLibrary: Could not load /p/pro/versioninfo.dll

??? Unable to load /p/pro/versioninfo.dll.
??? Cannot install Service Pack

Cause(s):
??? OS patch level for HP machine is not set as per Progress 9.1D requirements.
In this particular case PHSS_22543 is missing on the HP machine.

Fix:
Fix your OS patch level as per Progress Solution P16085 - http://esupport.progress.com/esupport/consumer/solutionarea.asp?id=P16085


HTH,

bk