General
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant 1850r Suse 8.2 Pro not using 2nd processor

SOLVED
Go to solution

Proliant 1850r Suse 8.2 Pro not using 2nd processor

Just when you think youre starting to get the hang of this Linux stuff, you get this to happen to you. I guess I moved back down to newbie status again.

Any one know to get SuSE 8.2 Pro to start using the second processor on a Proliant 1850r? If so, please try to be as thorough and complete and accurate as possible in your reply, as I dont want to torch this build of it (which was a tiny bit of a struggle).

Thank you.
7 REPLIES
Mark Grant
Honored Contributor

Re: Proliant 1850r Suse 8.2 Pro not using 2nd processor

Firstly, how do you know it isn't using the second processor? "dmesg" should show the output of querying two processors if you have them. Could you confirm?

If you really are running UP then you need to configure the kernel to as a multi processor kernel. It's a long time since I ran SuSe but they used to supply a multiprocessor enabled kernel as well as a uniprocessor one and it may be just a case of getting it and alter /etc/lilo.conf to point to it.

However, in the general case, you will need to build a new kernel with SMP support. I hesitate to give you the steps to do this because SuSe run with modified kernels and doing this might stop something else working. So, if you want to build your own kernel and still keep the old one around just in case, follow these steps.

Backup
become root

# export DISPLAY=:0
# cd /usr/src/linux (or where ever it is in Suse these days)

# make xconfig

Navigate around until you find the SMP option, I think it's one of the first options you are able to change.

change it to "y"

save and exit
# make dep

# make bzImage

# make modules
# make modules_install
# cp /boot/System.map /boot/system.map.prev

# cp /boot/vmlinuz /boot/vmlinuz.prev
# cp arch/i386/boot/bzImage /boot/vmlinuz

# cp System.map /boot/System.map

edit /etc/lilo.conf or grub.conf to include a n entry for your backup kernel image (vmlinuz.prev) or forget this if you like living dangerously

run either "lilo" or "grub" as required

# cross fingers

# re-boot


Never preceed any demonstration with anything more predictive than "watch this"
Martin P.J. Zinser
Honored Contributor

Re: Proliant 1850r Suse 8.2 Pro not using 2nd processor

Have a look at

ftp://ftp.suse.com/pub/suse/i386/8.2/suse/i586/
(or i686 depending on your CPUs) and look for

k_smp-2.4.20-62.i586.rpm

This should be a precompiled SMP kernel.

If you are using Lilo as the boot manager you should have a "failsafe" option by default (although it never hurts to have a backup kernel as suggested before ;-)
K.C. Chan
Trusted Contributor

Re: Proliant 1850r Suse 8.2 Pro not using 2nd processor

make sure your using an snmp supported kernel.
Reputation of a thousand years can be determined by the conduct of an hour

Re: Proliant 1850r Suse 8.2 Pro not using 2nd processor

I went ahead and chanced it. I installed the SMP kernel, ignored its warning about my being crazt to try it, rebooted, and, sure enough, it didnt come up, says it cant find a file. So I booted to "failsafe", ran YAST, tried to install the default kernel but it cant use the CDROM drive since it wont mount or cant find some files or something, so now the question is: how does one use the CDROM drive so I can install the default kernel again to get this baby to boot.
Martin P.J. Zinser
Honored Contributor

Re: Proliant 1850r Suse 8.2 Pro not using 2nd processor

Hello Jason,

quoting complete and undistorted error messages (preferably the first you receive) will greatly enhance your chances of getting good help.

As for the CD-Rom issue, can you boot directly from CD?

Greetings, Martin
Steven E. Protter
Exalted Contributor
Solution

Re: Proliant 1850r Suse 8.2 Pro not using 2nd processor

Hi Jason,

Any chance you can start over and do the install again off the original install cd's? at that point all the necessary components required by the smp kernel will be installed.

The smp kernel is the only one thats going to use both processors, so you need to get it and all pre-requisites installed.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Proliant 1850r Suse 8.2 Pro not using 2nd processor

Thanks very much to all who repsonded. I really appreciate it.

The last answer was the way I ended up going. Funny, I lost track of this thread, and came on this solution on my own, then I came back here to close this out, and, sure enough, the last suggestion was the way to go.

What I ended up doign was botting of CD #1, choosing install, then "upgrade", while making sure I chose "k_smp" (instead of default kernel (ie: "k_dftl")). It went through, and literaly, three minutes later I was up and running again, perfectly, on both CPU's. I then ran YaST to patch to the most recent kernel, that went straight through, and all is well.

Thanks again.