Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

QLogic Failover

C'est Pierre
Advisor

QLogic Failover

One of our servers, used to use the kernel's default driver and it worked greatly. Since there was 2 hbas on that server the lun appeared twice as /dev/sda and /dev/sdb.

Now we did a few updates on the server and decided to install the official driver and the 2nd path (sdb) disappeared, is this a side effect of the failover? meaning that the only path we access is sda which does all of the underlying magic (i.e choosing the FC which is working) ?
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: QLogic Failover

Shalom C'est,

You may have your SAN wired in a way that cause s this issue.

Check list:
1) Latest supported san surfer for your OS.
2) Latest qlogic drivers.
3) Latest drivers/firmware for your storage.
4) Make sure 1-3 are fully supported for your OS.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
C'est Pierre
Advisor

Re: QLogic Failover

We're using SuSE 9 with SP3 (9.3) and our storage is a recent EVA 3000. I guess they're supported, but I am not fully sure.

Is there anything else you can tell me about this setup?
Barry Lowe
Advisor

Re: QLogic Failover

When you say 'official driver' do you mean the one from HP or the one from QLogic. The one from QLogic is not supported as the HBA is OEM.

Try this (sorry, re-used from one of my previous posts):

cat /proc/scsi/qla2xxx/* | grep version

if the line ends with fo then you have failover configured.

This is usually activated by having something like this in modprobe.conf:

options qla2xxx ql2xfailover=1

This may have been activated by default after you installed the new driver. Conversely you could explicitly set the above parameter to 0 to de-activate the failover.

-----------

I also think an EVA is set to active/active, in which case what you have may be load balancing too. Please note I've never used an EVA so am no expert! You would know this if you were able to use both the sda and sdb paths prior to your upgrade.
C'est Pierre
Advisor

Re: QLogic Failover

Hello Barry,

I do mean the one from HP and there's no FO line and I've got this on my modprobe.conf:

options qla2xxx ql2xmaxqdepth=16 qlport_down_retry=30 ql2xloginretrycount=30 ql2xfailover=1 ql2xlbType=1 ql2xautorestore=0x0
remove qla2xxx /sbin/modprobe -r --first-time --ignore-remove qla2xxx && { /sbin/modprobe -r --ignore-remove qla2xxx_conf; }

I also have this file /etc/hp_qla2x00.conf:

qdepth = 16
port_down_retry_count = 30
login_retry_count = 30
failover = 1
load_balancing = 1
auto_restore = 0x0
Barry Lowe
Advisor

Re: QLogic Failover

I'd say you've got a fully functioning setup then. I've no experience of SuSE but what you have is very similar to the RH setup I am using with an MSA1000 (which is active-passive, so no load balancing).

If you have installed the full PSP you may find that it has installed some agents which keep a track of the status of your HBAs and may even log their status.
Alan_152
Honored Contributor

Re: QLogic Failover

Make sure you are using the driver released by HP, instead of the one directly from QLogic.