cancel
Showing results for 
Search instead for 
Did you mean: 

RHEL5 x86 & PSP 7.90

Toan_Nguyen
Occasional Advisor

RHEL5 x86 & PSP 7.90

Hi guys,

during the installtion process of PSP 7.90 I have been requested to install compat-gcc-32.3.2.3-47.2.i386.rpm.

I downloaded the rpm manually and installed it. BUT got following error message:

error: Failed dependencies

glibc-devel >= 2.2.90-12 needed to installcompat-gcc-32.3.2.3-47.2.i386.rpm


Please help


Thanks
3 REPLIES
~sesh
Esteemed Contributor

Re: RHEL5 x86 & PSP 7.90

This is a case of missing dependencies. You will need glibc-devel greater than version 2.2.xx-xx.

You can use RPMfind at http://rpmfind.net to get the required RPMs or look for them on the installation media.

For e.g. for glibc-devel-2.3.6-3.i386.rpm, look here:
http://rpmfind.net//linux/RPM/fedora/updates/4/i386/glibc-devel-2.3.6-3.i386.html
Toan_Nguyen
Occasional Advisor

Re: RHEL5 x86 & PSP 7.90

i could fixe the issue!
skt_skt
Honored Contributor

Re: RHEL5 x86 & PSP 7.90

if you wanted to see the depenencies for installed or going to install

rpm -q --requires for installed rpm.

rpm -qp --requires for not installed rpm.

Then you can go over the list with this command:
"rpm -q --whatprovides " and it will return you the package name.


#rpm -q --requires lftp-2.6.3-6
/bin/sh
config(lftp) = 2.6.3-6
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.2.3)
libc.so.6(GLIBC_2.2.4)
libc.so.6(GLIBC_2.3)
libcrypto.so.4
libdl.so.2
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libm.so.6
libm.so.6(GLIBC_2.0)
libncurses.so.5
libnetwork.so
libreadline.so.4
libresolv.so.2
libresolv.so.2(GLIBC_2.2)
libssl.so.4
libutil.so.1
libutil.so.1(GLIBC_2.0)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1


# rpm -q --whatprovides libc.so.6
glibc-2.3.2-95.44