Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Showing results for 
Search instead for 
Did you mean: 

RHEL5 x86 & PSP 7.90

Occasional Advisor

RHEL5 x86 & PSP 7.90

Hi guys,

during the installtion process of PSP 7.90 I have been requested to install compat-gcc-

I downloaded the rpm manually and installed it. BUT got following error message:

error: Failed dependencies

glibc-devel >= 2.2.90-12 needed to installcompat-gcc-

Please help

Esteemed Contributor

Re: RHEL5 x86 & PSP 7.90

This is a case of missing dependencies. You will need glibc-devel greater than version 2.2.xx-xx.

You can use RPMfind at to get the required RPMs or look for them on the installation media.

For e.g. for glibc-devel-2.3.6-3.i386.rpm, look here:
Occasional Advisor

Re: RHEL5 x86 & PSP 7.90

i could fixe the issue!
Honored Contributor

Re: RHEL5 x86 & PSP 7.90

if you wanted to see the depenencies for installed or going to install

rpm -q --requires for installed rpm.

rpm -qp --requires for not installed rpm.

Then you can go over the list with this command:
"rpm -q --whatprovides " and it will return you the package name.

#rpm -q --requires lftp-2.6.3-6
config(lftp) = 2.6.3-6
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

# rpm -q --whatprovides