cancel
Showing results for 
Search instead for 
Did you mean: 

RP4440 no CDROM is detected

zinelabidine
Advisor

RP4440 no CDROM is detected

Hi,

I want to install HP-UX 11iV1 in RP4440 server, But when i give the command SEARCH no cdrom is detected.

the command ioscan —fnkCdisk give the following lines:
# ioscan -fnkCdisk
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
disk 1 0/1/1/0.1.0 sdisk CLAIMED DEVICE HP 73.4GST373455LC
/dev/dsk/c2t1d0 /dev/rdsk/c2t1d0
disk 2 0/1/1/1.0.0 sdisk CLAIMED DEVICE HP 73.4GST373455LC
/dev/dsk/c3t0d0 /dev/rdsk/c3t0d0


So no cdrom is detected.

Thank you.
14 REPLIES
Ganesan R
Honored Contributor

Re: RP4440 no CDROM is detected

Hi,

Check the cdrom is connected properly and powered on.

if the cdrom is connected properly and powered on, ioscan should show with atleast some status.
Best wishes,

Ganesh.
zinelabidine
Advisor

Re: RP4440 no CDROM is detected

I have an internal cdrom. i can open it and put inside it a cd.
But when i give the command :ioscan -fnC disk it gives just 2 hard disk of rp4440 server.


ioscan -fnC disk
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
disk 1 0/1/1/0.1.0 sdisk CLAIMED DEVICE HP 73.4GST373455LC
/dev/dsk/c2t1d0 /dev/rdsk/c2t1d0
disk 2 0/1/1/1.0.0 sdisk CLAIMED DEVICE HP 73.4GST373455LC
/dev/dsk/c3t0d0 /dev/rdsk/c3t0d0
#
R.K. #
Honored Contributor

Re: RP4440 no CDROM is detected

Hi,

Why not try the same CD-ROM in another server, may be the CDROM is faulty.

Regds,
R.K.
Don't fix that what ain't broke
zinelabidine
Advisor

Re: RP4440 no CDROM is detected

Hi,

CD-ROM is working inside an other CDROM.
DeafFrog
Valued Contributor

Re: RP4440 no CDROM is detected

Hello Zinelabidine,

Try #insf -eC disk and then #ioscan -fnC disk.

Regards ,
Rahul
FrogIsDeaf
zinelabidine
Advisor

Re: RP4440 no CDROM is detected

hello Rahul,

# insf -eC disk
insf: Installing special files for sdisk instance 1 address 0/1/1/0.1.0
insf: Installing special files for sdisk instance 2 address 0/1/1/1.0.0
# ioscan -fnC disk
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
disk 1 0/1/1/0.1.0 sdisk CLAIMED DEVICE HP 73.4GST373455LC
/dev/dsk/c2t1d0 /dev/rdsk/c2t1d0
disk 2 0/1/1/1.0.0 sdisk CLAIMED DEVICE HP 73.4GST373455LC
/dev/dsk/c3t0d0 /dev/rdsk/c3t0d0
#

It still the same thing.

Br
Zinelabidine

zinelabidine
Advisor

Re: RP4440 no CDROM is detected

Hi,

In this case what i should do to solve this problem.

Thank you
Duncan Edmonstone
Honored Contributor

Re: RP4440 no CDROM is detected

If you don't see the DVD drive from the OS or BCH, it suggests that it either:

- Is broken
- Isn't connected

Either way if the box is still in warranty or under support you should log a hardware call with HP.

One thing I note from above is that you are only looking in the kernel... (the ioscan -k option)

Could you post a full ioscan output:

ioscan -f

HTH

Duncan

HTH

Duncan
zinelabidine
Advisor

Re: RP4440 no CDROM is detected

Hello Duncan,

#iosan -f gives the following result:

[Class I H/W Path Driver S/W State H/W Type Description............................... OK ScRoll [ON|OFF] Dis
=============================================================================................................ OKELftests [ON|OFF] Enable/di
root 0 root CLAIMED BUS_NEXUSitoring daemon ................................. OKI|ALT|ioa 0 0 sba CLAIMED BUS_NEXUS System Bus Adapditing subsystem ............................................ N/Aisplay the curr
ter (880) /dev/
ba 0 0/0 lba CLAIMED BUS_NEXUS Lo daemon .............. D-e ,ioscan -fnC d
MAin Re
Start USB hub daemon ....
(103c1290)..........
tty 1 0/0/1/1 asio0 CLAIMED INTERFACE PCI Serial (103_cart:last_cart] [-s


SAM System administration configuration ............
c1048)......
usb 0 0/0/2/0 hcd CLAIMED INTERFACE NEC USB Interfar I
MeasureWare performance software is being started. .................. O
cest
usbhub 0 0/0/2/0.1 hub CLAIMED DEVICE USB Root Hub Configure PRM -or- Configure and Enable PRM ......................... N/Ale

usb 1 0/0/2/1 hcd CLAIMED INTERFACE NEC USB InterfaStarting ObAM Application Server .................................... N/A 7
ce
usbhub 1 0/0/2/1.1 hub CLAIMED DEVICE USB Root Hublize Software Distributor agent d
0/5/2/0 7 MAX UNKNOWN
Configu
lerP R
ext_bus 0 0/0/3/0.0 side CLAIMED INTERFACE IDE Primary Cha7 MAX UNKNOWN MAXal files for sdisk
Copy processor log
nnel/var
target 0 0/0/3/0.0.7 tgt CLAIMED DEVICE---- 1
insf: Inst

---- Service Menu ------------------
ctl 0 0/0/3/0.0.7.0 sctl CLAIMED DEVICE Initiator..... OK-- 1 ro
insf: Installing special fi

Command
ext_bus 1 0/0/3/0.1 side CLAIMED INTERFACE IDE Secondary C..... OK -----------tl instance 4 address 0/4/1/0.7.0
hannel Co
target 1 0/0/3/0.1.7 tgt


6961-60111rting VxRS
target 4 0/1/1/1.0 tgt CLAIMED DEVICEiles for pseudo d
HElp [] D
disk 2 0/1/1/1.0.0 sdisk CLAIMED DEVICE HP 73.4GST37345......... OKcrw-rw-rw-
RESET Restart the sys
5LCfor
target 5 0/1/1/1.7 tgt CLAIMED DEVICE.................. OK Return to Main Menudo dr
ctl 3 0/1/1/1.7.0 sctl CLAIMED DEVICE Initiator........................................ N/A
#

PAGE DEALLOCATION
lan 0 0/1/2/0 iether CLAIMED INTERFACE HP AB352-60003........................................... OKtunip
insf: Installing special fi
PCI/PCI-X 1000Base-T Dual-port Core-------
Starting PRNGD (Pseud
(c)Copyright 1990 Motorola, Inc.a
ctl 4 0/4/1/0.7.0 sctl CLAIMED DEVICE Initiatorrsityty1p0 /dev/
insf: Installing special files f
(c)Copyright 1989-19
ext_bus 5 0/4/1/1 mpt CLAIMED INTERFACE SCSI Ultra320 A)Copyright 1988 Carnegie Mellon University
ScRoll [ON|OFF]
6961-60111opyright 1
target 8 0/4/1/1.7 tgt CLAIMED DEVICEopyright 1996 Morning
lan 3 0/4/2/0/4/1 iether CLAIMED INTERFACE HP AB545-60001
PCI/PCI-X 1000Base-T 4-port 1000B-T Adapter
lan 4 0/4/2/0/6/0 iether CLAIMED INTERFACE HP AB545-60001
PCI/PCI-X 1000Base-T 4-port 1000B-T Adapter
lan 5 0/4/2/0/6/1 iether CLAIMED INTERFACE HP AB545-60001
PCI/PCI-X 1000Base-T 4-port 1000B-T Adapter
ba 5 0/5 lba CLAIMED BUS_NEXUS Local PCI-X Bus
Adapter (783)
ba 6 0/5/1/0 PCItoPCI CLAIMED BUS_NEXUS PCItoPCI Bridge
lan 6 0/5/1/0/4/0 iether CLAIMED INTERFACE HP AB545-60001
PCI/PCI-X 1000Base-T 4-port 1000B-T Adapter
lan 7 0/5/1/0/4/1 iether CLAIMED INTERFACE HP AB545-60001
PCI/PCI-X 1000Base-T 4-port 1000B-T Adapter
lan 8 0/5/1/0/6/0 iether CLAIMED INTERFACE HP AB545-60001
PCI/PCI-X 1000Base-T 4-port 1000B-T Adapter
lan 9 0/5/1/0/6/1 iether CLAIMED INTERFACE HP AB545-60001
PCI/PCI-X 1000Base-T 4-port 1000B-T Adapter
ba 7 0/6 lba CLAIMED BUS_NEXUS Local PCI-X Bus
Adapter (783)
memory 0 8 memory CLAIMED MEMORY Memory
ipmi 0 16 ipmi CLAIMED INTERFACE IPMI Controller
processor 0 128 processor CLAIMED PROCESSOR Processor
processor 1 129 processor CLAIMED PROCESSOR Processor
#

thank you

Br
Zinelabidine
Duncan Edmonstone
Honored Contributor

Re: RP4440 no CDROM is detected

Don't know what happened with a simple cut/paste there, but I can't make out anything in that mess.

On a *good* rp4440 system, the DVD drive would appear under the HW path 0/0/3/0:

sideba 0 0/0/3/0 side_ba CLAIMED INTERFACE CMD IDE
controller
ext_bus 0 0/0/3/0.0 side CLAIMED INTERFACE IDE
target 0 0/0/3/0.0.0 tgt CLAIMED DEVICE
disk 0 0/0/3/0.0.0.0 sdisk CLAIMED DEVICE TEACDW-224E
/dev/dsk/c0t0d0 /dev/rdsk/c0t0d0

So from what I *think* I can maek out in that mess, you don't have that entry - which I guess means the drive is dsiconnected or broken...

HTH

Duncan


HTH

Duncan
zinelabidine
Advisor

Re: RP4440 no CDROM is detected

Hi,

By using the command ioscan -k i get the following lines :

......
Path# Device Path (dec) Device
0/0/2/0.1 usbh
xx SAM Logical Volumes
0/0/3/0 sideba CMD IDE controllerLAIMED I
insf: Installing special files

.......

So the path of cdrom is /0/0/3/0 i guess.

What should I do then?

Thanx
Duncan Edmonstone
Honored Contributor

Re: RP4440 no CDROM is detected

No - that's the path to the IDE controller that the DVD would be on if you could see it...

The actual path to he DVD drive would be:

0/0/3/0.0.0.0

Why is the formatting of your pasted output so messed up? What are you pasting from?

HTH

Duncan

HTH

Duncan
zinelabidine
Advisor

Re: RP4440 no CDROM is detected

Hi,

Sorry i'm connecting to server via serial port so for that is parsing is so bad.

Thank you

zinelabidine
Torsten.
Acclaimed Contributor

Re: RP4440 no CDROM is detected

This is the IDE part should look like:

sideba 0 0/0/3/0 side_ba CLAIMED INTERFACE CMD IDE control
ler
ext_bus 0 0/0/3/0.0 side CLAIMED INTERFACE IDE Primary Cha
nnel
target 0 0/0/3/0.0.0 tgt CLAIMED DEVICE
disk 0 0/0/3/0.0.0.0 sdisk CLAIMED DEVICE TEAC DV-28E-
N
/dev/dsk/c0t0d0 /dev/rdsk/c0t0d0
target 1 0/0/3/0.0.7 tgt CLAIMED DEVICE
ctl 0 0/0/3/0.0.7.0 sctl CLAIMED DEVICE Initiator
/dev/rscsi/c0t7d0
ext_bus 1 0/0/3/0.1 side CLAIMED INTERFACE IDE Secondary C
hannel
target 2 0/0/3/0.1.7 tgt CLAIMED DEVICE
ctl 1 0/0/3/0.1.7.0 sctl CLAIMED DEVICE Initiator
/dev/rscsi/c1t7d0


If the IDE controller is CLAIMED, you likely have a bad drive. Can you confirm you have a drive at all? ;-))

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!