General
cancel
Showing results for 
Search instead for 
Did you mean: 

RPM Upgarding problem with libstdc++

Eli_pok
Frequent Advisor

RPM Upgarding problem with libstdc++

Hi,

I'm using Red-Hat 4.4, and trying to update libstdc++ (the current version is 3.4.6-3) to version 4.0.2-8.

When i try to update (using rpm -Uvh) i get the following errors (Failed Dependencies):
libstdc++ = 3.4.6-3 is needed by (installed) libstdc++-devel-3.4.6-3.i386
libstdc++ = 3.4.6 is needed by (installed) gcc-c++3.4.6-3.i386

As the errors indicate, libstdc++-devel-3.4.6-3.i386 and gcc-c++3.4.6-3.i386 are already installed!

I'm trying to figure out what RPM means by that.

My assumption is that RPM tries to remove libstc++ old file(s) in order to replace it with the new one(s) and fails because gcc-c++ and libstc++-devel need it.

Am i right?
Do I need to upgrade libstc++-devel and gcc-c++ to the same version of libstdc++ first and only then upgarding libstc++ ?

6 REPLIES
Michal Kapalka (mikap)
Honored Contributor

Re: RPM Upgarding problem with libstdc++

hi,

check this link :

http://www.centos.org/modules/newbb/print.php?form=1&topic_id=6154&forum=27&order=ASC&start=0

- you could use yum for ths action, yum will select automaticaly what are the dependiency for your libstdc++

mikap
Steven E. Protter
Exalted Contributor

Re: RPM Upgarding problem with libstdc++

Shalom,

You need to update these two apps.

libstdc++-devel-3.4.6-3.i386

gcc-c++3.4.6-3.i386


yum update takes care of these issues more smoothly. Centos yum can be installed on RHEL 4

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Michal Kapalka (mikap)
Honored Contributor
Eli_pok
Frequent Advisor

Re: RPM Upgarding problem with libstdc++

I didn't mention that it's a close orgazniztion, so we have our own yum repository (with version 3.4.6-3 for all those rpm).

I'll try to update libstdc++-devel and gcc-c++ first
dirk dierickx
Honored Contributor

Re: RPM Upgarding problem with libstdc++

either remove the devel and gcc packages, or update devel and gcc packages at the same time (it's one rpm command, just specify all packages at the same time after eachother).
Court Campbell
Honored Contributor

Re: RPM Upgarding problem with libstdc++

Of the subject, but I miss it when the --aid option to rpm used to work.
"The difference between me and you? I will read the man page." and "Respect the hat." and "You could just do a search on ITRC, you don't need to start a thread on a topic that's been answered 100 times already." Oh, and "What. no points???"