Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

Red Hat 3.0 NIC bonding

SOLVED
Go to solution
Sandeep Sanjao Figer
Frequent Advisor

Red Hat 3.0 NIC bonding

Hi,

I have HP DL 380 G4 with Red Hat AS 3.0. I am having trouble enabling bonding on my eth0 & eth1. I tried to play around with various options in modules.conf, ifcfg-eth0, ifcfg-eth1, bond0 etc but no luck. Have to manually up the eth1 interface which gives error anyway. Would appreciate some help on the same.

Regards,
Sandy
10 REPLIES
Chakravarthi
Trusted Contributor

Re: Red Hat 3.0 NIC bonding

were u able to load the driver modle? can you give the error message
Sandeep Sanjao Figer
Frequent Advisor

Re: Red Hat 3.0 NIC bonding

Hi,
I can load the driver but it doesn't seem to be working when the system is up. In the Network panel, it shows inactive.
Regards,
Sandeep
Gallig Renaud
Occasional Advisor
Solution

Re: Red Hat 3.0 NIC bonding

Hi,

What do you mean by: "Have to manually up the eth1 interface which gives error anyway" ?

Setting up bonding is usually pretty easy on RedHat. Your configurations files should be as follow (do not remove lines in /etc/modules.conf, only add and change the ones that are different):

/etc/modules.conf
alias eth0 bcm5700
alias eth1 bcm5700
alias bond0 bonding
options bond0 miimon=100 mode=0

(if you did not install Proliant Support Pack, bcm5700 drivers may not be there. The best solution will be to install it. If for some reasons, you do not want to install it, use tg3 drivers instead: alias ethX tg3)
(You can change options as well: mode 0 is Load balancing Server to Switch only, ALB)

/etc/sysconfig/network-scripts/ifcfg-ethX
DEVICE=ethX
BOOTPROTO=none
ONBOOT=yes
SLAVE=yes
MASTER=bond0
USERCTL=no

/etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
BOOTPROTO=static
ONBOOT=yes
IPADDR=
NETMASK=

Then restart your network service and everything should be fine.
Hope this help.
Gopi Sekar
Honored Contributor

Re: Red Hat 3.0 NIC bonding


if eth1 is inactive when system boots up then may be ONBOOT flag is not enabled for it.

edit /etc/sysconfig/network-scripts/ifcfg-eth1 and set ONBOOT=yes

reboot the system and eth1 should be enabled automatically.

Never Never Never Giveup

Re: Red Hat 3.0 NIC bonding

Perhaps this manual may help you:

http://docs.hp.com/en/B9903-90043/B9903-90043.pdf

refer to page 149 as a starting point
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Sandeep Sanjao Figer
Frequent Advisor

Re: Red Hat 3.0 NIC bonding

Hi,

Tried initially with Gallig Renaud's suggestion. Both the NIC's do up come normally & bond0 shows okay while boot. Somehow I was not able to ping any other machine. Did deactive & active again & it was fine. Did a normal reboot again & it seems to be ok. I see lot of other entries as per the word attachement from the zip file in Network Graphics panel. Not a very Linux expert & so just not sure why all those backup files I had made like ifcfg-eth0_may9 & so on also get loaded. They are present in different locations as well. I had just modified files as per Gallig Renaud's suggestion
I have attached the files for the reference.


Regards,
Sandeep
Gopi Sekar
Honored Contributor

Re: Red Hat 3.0 NIC bonding


in the second image you have showed a graphics containg ftp transaction. i dont know is it ftp to local system or you are ftp-ing to remote system?

few things to check for:

check any firewall is blocking your traffic. run /etc/init.d/iptables stop and run ping command, see whether it works.

if still not working, time to check for individual ethernet cards. remove the bonding (i know its pain), connect ethernet cards individually(with separate ip) and see whether it pings to any destination machine.

Hope this helps,
Gopi
Never Never Never Giveup
Steven E. Protter
Exalted Contributor

Re: Red Hat 3.0 NIC bonding

An additon to the start section of /etc/init.d/network

start)
/sbin/modprobe bonding mode=1 miimon=100


You need to monitor the connection for it to work right.

I have this working though bond0 shows incorrect speed, I'm getting Gigabit throughput with Intel NIC cards and ES 4.0

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Sandeep Sanjao Figer
Frequent Advisor

Re: Red Hat 3.0 NIC bonding

Gopi,

As said in my last email, bonding is working ok now but just not sure why there are multiple entries in Network option for configuration files. Ignore the FTP scree as it was another job I was doing..

Just wanted to ensure that correct ifcfg-eth0, ifcfg-eth1 & bond0 were getting loaded.

Regards,
Sandep
Gopi Sekar
Honored Contributor

Re: Red Hat 3.0 NIC bonding


ok, i think i got it wrong, sorry.

i feel ifcfg-eth0.orig, ifcfg-eth0_may9 or backup or duplicate entries which either you created or system created.

these are not required as only eth0 and eth1 is being used for bond0

you can leave them, they are not going to do any harm or simply delete them using GUI.

if you are not very sure, then move all duplicate ifcfg* files (from /etc/sysconfig/) to another location, reboot the system and see whether everything works fine and if you are pretty sure then delete the moved files.

Gopi
Never Never Never Giveup