Red Hat Cluster suite 5 question

 
SOLVED
Go to solution

Red Hat Cluster suite 5 question

Hi All,

Cluster package unable to failover when node 1 when press the power button directly. Even though has already upgrade the ilo firmware from 1.30 to 1.42.

27 REPLIES 27

Re: Red Hat Cluster suite 5 question

Is heartbeat is still been use in red hat cluster suite 5.
Appreciate anyone that reply and help.

thanks.
Ivan Ferreira
Honored Contributor

Re: Red Hat Cluster suite 5 question

Probably node 2 cannot fence node 1 properly. What fence device are you using?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?

Re: Red Hat Cluster suite 5 question

Hi,

I'm using hp ilo to fence both node. Both node 1 and node to fence to another server hp ilo.

thanks.
Ivan Ferreira
Honored Contributor

Re: Red Hat Cluster suite 5 question

What do you get in /var/log/messages, have you confirmed that fencing is working?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Steven E. Protter
Exalted Contributor

Re: Red Hat Cluster suite 5 question

Shalom,

Test manually that you can connect to ilo and do a power reset on the server.

RH4 required a password be hard coded in the cluster.conf file. Use that password to manually test ilo.

This could be a simple problem of not having the correct authentication. It could also be a bad ilo card.

service fenced status

both nodes please.

iLo cards need to be on the same network and be able to talk to each other.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Red Hat Cluster suite 5 question

Hi all,

How should my fence physical connection to be. As, Physical connection is that both node only use 2 network port to do bonding and i just use another server ilo port to fence both node. Is this workable. All the ipaddress has been configure in the same network/ segment.

Thanks.

Ivan Ferreira
Honored Contributor

Re: Red Hat Cluster suite 5 question

It does not matter as long as the ILO and your public network are in the same subnet. What about the messages? Is your ILO configuration correct?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?

Re: Red Hat Cluster suite 5 question

I have check the configuration few times. I'm sure i have configure properly. In the cluster log there is no error for the ilo. Besides cluster log is there another log for ilo?

Re: Red Hat Cluster suite 5 question

this cluster suite is making me go crazy. Today try to setup the fence device by using HP ilo where by using the both node ilo port. Someone has hardcode the ilo on node 2(ml370 g3)now everytime i press f8 it will prompt for username and password. did ask the owner on that machine but don't remember the username and password. Is there a way to reset the ilo.?