Re: RedHat 9 and ML350

Mark Blum_1
New Member

RedHat 9 and ML350

I'm trying to install RH 9 on a 350 and keep getting CD Not Found after selecting Local CDROM for the installation method. I tried the nodma switch.
Honored Contributor

Re: RedHat 9 and ML350

I Suppose you are booting from a bootimag/floppy?, doing a full install from scratch and that the install stops when you answer cdrom at the screen where it ask for installation method ?

I read the install part of the RH 9 yesterday before upgrading 3 different laptop/desktops, run into a similar problem, but in my case I could boot from the cdrom ... begin install until when it ask for the methode I wanted to use ... then I failed finding the cdrom It had been using !!!?

I suppose that there is something wrong with the iso cd I burned the first one booted and started install but then failed finding the cdrom (perhaps some confilt between atapi/scsi ?)to install from no matter what I try to pass it at boot time. (I gave up on this not wishing to wast to much time)

In my case I still had the 3 iso images on disk of one of the upgradable sytem's so I sftp copied these by network to other system and used on local hardisk install

this turn out to be quite fast!

now the reason I am saying all of this is probably the cause of all that is it you may need some additional drivers !

The Red Hat Linux CD-ROM 1 includes driver diskette images (including
images/drvnet.img -- network card drivers and images/drvblock.img --
drivers for SCSI controllers) containing many drivers (both common and
obscure). If you suspect that your system may require one of these
drivers, you should create the driver diskette before beginning your
Red Hat Linux installation.

Could be you need this additional image floppy to identify your cdrom.

If my supposition where wrong or this does not help let us know.

Smile I will feel the difference
Kodjo Agbenu
Honored Contributor

Re: RedHat 9 and ML350

Do you use genuine Red Hat CDs or downloaded and self burned ones ?

A very simple test : try to install another distro or another Red Hat version. If it works, your cd-rom drive is OK. Otherwise, try to have it replaced.

Good luck.

Learn and explain...
Mark Blum_1
New Member

Re: RedHat 9 and ML350

Adding the 2 driver disks didn't work.

I am using downloaded and self burned CD's. I saw in another post about using a slower speed for burning, and tried 4X. But it didn't work either.
Honored Contributor

Re: RedHat 9 and ML350

I havent had time to find out why my iso cd did not work... no progess there but I found this also in redhat install doc... perhaps this will help

------ --------
If you have an IDE (ATAPI) CD-ROM, but the installation program fails to find your IDE (ATAPI) CD-ROM and asks you what type of CD-ROM drive you have, try the following boot command. Restart the installation, and at the boot: prompt enter linux hdX=cdrom. Replace the X with one of the following letters, depending on the interface the unit is connected to, and whether it is configured as master or slave (also known as primary and secondary):


a ??? first IDE controller, master

b ??? first IDE controller, slave

c ??? second IDE controller, master

d ??? second IDE controller, slave

If you have a third and/or fourth controller, continue assigning letters in alphabetical order, going from controller to controller, and master to slave.

------------- ---------------

I will try figure out why my bootable iso cd could boot but then failed to continue installed when I choses method ?, will also try the above work around just havent had time.

keep us informed of progress.

Smile I will feel the difference
Honored Contributor

Re: RedHat 9 and ML350

I have now written RH9 shrike-i386-disc1.iso on a
CDRW cd using just the following cmd

cdrecord dev=0,0 speed=8 shrike-i386-disc1.iso
this is the same iso and cmd i used last time !!? at least I think so

(do a cdrecord -scanbus to see your dev value)

I then booted this new CDRW and started upgrade

no problem this time ??? It now see/knows aboute my cdrom ...

the first cd I burned must be corrupted ? or I must have done something wrong !?

the above is not of much help to you !

One additional think you could do is use

>ALT> and > after you get the CD Not Found message

This will put you in the 2 diff console log message screen ... it could provide you with more informations.

Let us know how you get a long


Smile I will feel the difference
Gianluca Cecchi

Re: RedHat 9 and ML350


Hp has developed a fix for the broken installation process that affects at
least the following list of ProLiant servers:

The fix is in the form of a boot floppy that is used in conjunction
with the installation CD.

The readme and floppy images are available externally here:

The RH9 installation boots but prompts for the location of the installation files and cannot locate them on the CD media.

This is a bug in the ide driver that affects CD-ROM access in the installation kernel only.
After the installation is complete, the
installed kernel does not contain the bug and functions correctly.

IMPORTANT NOTE: even if Hp has provided
the fix, RH 9 is not certified (by Hp) with ProLiants server: check at

RedHat has been given the fix to insure that AS 3.0 (based on RH9) won't have
this issue.

- dd the image to a floppy:
dd bs=36b < bootdisk.img > /dev/fd0

- Boot the server and enter the ROM based setup (F9), select the
Boot Order (IPL)" entry and select the floppy as the first boot device

- Insert both the boot floppy and the RedHat CD #1 and boot the system


The Penguin is one step ahead...
Mark Blum_1
New Member

Re: RedHat 9 and ML350

Thank you.
Vitaly Karasik_1
Honored Contributor

Re: RedHat 9 and ML350

10x isn't enough :-)

Rafael Bayona
New Member

Re: RedHat 9 and ML350

Hi, I had the same problem and the floppy helped, but not enough, still with problems. Now I can't see the hard drives. I have the following error:

<4> CRC Value mismatch
<4> (SCSI0:A:1:0): parity error detected in Date-in phase. SEQADDR (0x77) SCSIRATE (0xc2)

anaconda starts, but it freezes when I reach the format hard drives section. Of course, for linux there aren't! :D

By the way, Hard drives seem to work fine since in the boot section, BIOS seem to recognize them, and leds are green, but they turn off when the instalation process starts.

Any ideas?

Thanks for your support,