Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Redhat 9 Monitor Probelm

clarence_3
Occasional Advisor

Redhat 9 Monitor Probelm

I was interested in Linux so I downloaded Knoppix which ran fine on my sytem and since I really liked it I decided to install Redhat 9. during install, it detects my monitor and video card properly. My problem is that after I install it, or if I try to install in graphic mode, I lose signal to my monitor. Its almost liek it just turns off (green light turns orange). I thought it might be an high frequency problem, but when I've gone over frequncy before I get an error on my monitor that says frequency overrange. With redhat it just goes blank and I get no sort of message saying frequency overrange. This happens everytime I try to boot into Redhat after install. I checked it out on my TV and I see that it does go to the Redhat startup screen, but I just can't see it on my monitor for some reason. I've heard of using redhat-config-xfree86 or xf86config to adjust stuff but since I'm a total n00b I'm not sure how to do so.
Any help would be greatly appreciated, thanks.


Ps

my monitor is a hyundai imagequest q770 and my vid card is a e-gforce fx5200


12 REPLIES
Steven E. Protter
Exalted Contributor

Re: Redhat 9 Monitor Probelm

Try the install in text mode.

Choose a generic monitor and see how the installation goes.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Alexander Chuzhoy
Honored Contributor

Re: Redhat 9 Monitor Probelm

boot your pc into init 3.This runlevel doesn't start X by default.Then login and run redhat-config-xfree86
if you'll get a window than just select 800x680 with 16k colours.
if you won't get a window-let us know.
If it's too dificult to boot into runlevel 3. Then I suggest you to reinstall everything once again and at the end of the installation when you'll be prompt to choose wheither to start X on boot-choose not to start X.
This way you 'll be able to troubleshoot.

clarence_3
Occasional Advisor

Re: Redhat 9 Monitor Probelm

I'm not sure if I know how to boot into init 3.

I used went into the linux rescue and typedredhat-config-xfree86 and all I got was this error:
Fatal IO error 2 (connection closed by peer) on X server :17.0.

I did take someone elses advice and did this:

Once there you should be able to edit the file inittab with vi:
# vi inittab
Edit the line [b]id:5:initdefault:[/b], you know by first pressing instert, then a little [b]insert[/b] message appears in the bottom left corner, you can edit now and simply to save press ESC and type :x.

But that didn't do anything.

Someone else recommended this:

You need to change the HorizSync and VertRefresh of your monitor. The file you need to edit is call XF86Config or XF86Config-4 depends which on your XFree86 is using.
It is located in:
/etc/X11/
Open the file and look for the monitor section and change the values accordingly.
The HorizSync and VertRefresh of you monitor should be specified in monitor manual or on the manufacture's website

but when I go into the rescue console it alwasy says there is no /etc/X11/ directory.

I'm at a total loss. I'd really like to get Redhat running.
clarence_3
Occasional Advisor

Re: Redhat 9 Monitor Probelm

Oh yeah, I did install Redhat in text mode just fine (i did a dual boot with XP pro) and I can load XP pro fine which is what I'm using now. i don't have another monitor to try running redhat on, though.
clarence_3
Occasional Advisor

Re: Redhat 9 Monitor Probelm

well I figured out how to boot into init 3,


"In the graphical GRUB boot loader screen, select the Red Hat Linux boot label and press [e] to edit it.

Arrow down to the kernel line and press [e] to edit it.

At the prompt, type init 3 and press [Enter].

You will be returned to the GRUB screen with the kernel information. Press the [b] key to boot the system into init 3 mode."


However it eventually loads to a screen that says knoppix login. Whats up with that? It won't accept any passwords or logins that I might use, so I'm not sure what to do.
Alexander Chuzhoy
Honored Contributor

Re: Redhat 9 Monitor Probelm

This sounds like you didn't install redhat correctly and you still have knoppix.
Try to reinstall once again. While deciding what partitions to use - delete all the existing (exept the one with Windows XP)
and then create new partitions.
Best regards.
clarence_3
Occasional Advisor

Re: Redhat 9 Monitor Probelm

hmmm, wel I did what you suggested (deleted linux partitions and created new ones to isnatll to) but I still get the knopix login screen when i try to boot into init 3. Weird.
Alexander Chuzhoy
Honored Contributor

Re: Redhat 9 Monitor Probelm

Go here and see if you've missed something.If so-then do it step step by step according the manual:
http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/install-guide/
Jerome Henry
Honored Contributor

Re: Redhat 9 Monitor Probelm

On your grub screen, select your linux line, edit it, and add at the end of the line ' single'.
It'll have you boot in single mode, and get a prompt.
When you have it :
edit (vi) /etc/inittab, and change default:5 to default:3, so you'll boot in text mode.
It's easier than doing it the old way.
Do you have several disks ? Could you post here the partitions you have ?
If you reinstall redhat, make sure on screen configuration, when having the 'not probed' part of the screen that refers to your video card and screen, to select a card and screen that seem close to yours, and to click on test, before going further. Thus you can test many configurations before having to boot on one.
Make sure also to have grub on mbr, not first sector...

hth

J
You can lean only on what resists you...
clarence_3
Occasional Advisor

Re: Redhat 9 Monitor Probelm

well I have an external harddrive, but I don't have nay operating systems on it I just se it for storage, otheriwse I just ahve te one harddrive in my PC.

I have a linux ext2 primary partition with Redhat on it, a linux ext3 primary partition for the boot, and a linux swap logical partition. Plus and NTFS primary partition with windows xp pro on it.
clarence_3
Occasional Advisor

Re: Redhat 9 Monitor Probelm

well after logging into root at the knoppix login screen I checked out:
/var/log/XFree86.0.log

And I noticed this:

(--) PCI: *(1.0.0) nVIDIA Corporation unknown chipset...blah...blah...blah

I wonder if that has somethign to do with my problems?

I then got into XF86Config and this is some of my information although I'm not sure what to do with it, or what it means:

Section "Monitor"
identifier: "Monitor0"
vendorname: "Monitor Vendor"
ModelName: "DDCPROBED"
DisplaySize: 320 240
HorizSync: 30.0 - 70.0
VerticalRefresh: 50.0 - 150.0
Option: "dpms"

Section "Device"
Identifier: "Videocard0"
Driver: "Vesa"
VendorName: "Videocard Vendor"
BoardName: "Vesa driver (generic)"

Section "screen"
Identifier: "Screen0"
Device: "Videocard0"
Monitor: "Monitor0"
Default Depth: 24
Subsection "display"
Depth: 24
Modes: "800x600" "640x480"
clarence_3
Occasional Advisor

Re: Redhat 9 Monitor Probelm

Alright I changed the device driver to "nv" and that did the trick. I was able to boot into redhat!

thanks a lot for your help everyone.