Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Remote X App. on RH 7.3

SOLVED
Go to solution
Miguel Covas
Advisor

Remote X App. on RH 7.3

I have a brand new RH 7.3 installed and I am unable to launch applications on our rp7400 servers (HP-UX 11.0).

I did
# xhosts +

then logged in , then
$ export DISPLAY=:0
then
$ gpm (Glance Plus Manager)

I get
Connecting to Display...
Error: Can't open display :0
Error: Couldn't find per display information

Am I missing something?
Some package that I did not install?

I have another workstation with RH 7.2 and it works fine. So it can be done...
8 REPLIES
Stuart Browne
Honored Contributor

Re: Remote X App. on RH 7.3

When you say you did "xhosts +", I take it to mean you ran:

xhost +

(note: singular, as 'xhosts' doesn't exist). After issuing that command, what does 'xhost' on it's own report?

From the HP-UX machine, can you simply 'ping my.wkstation'? Just to ensure end-to-end connectivity.

Once you've done that, try using 'DISPLAY=:0.0', instead of just the ':0'. Some applications are picky.

Given the error messages you've given us, it would most likely be one of those things.

It doesn't look like you've missed installing any packages or anything of the like. Just looks like it's a niggly little annoying thing.

Something else to test would be to just try launching an xterm. I'm not 100% sure if the xterm command can take a '--display', but if it can, then issue:

xterm --display :0.0 &

and see if that connects..
One long-haired git at your service...
I_M
Honored Contributor

Re: Remote X App. on RH 7.3

Hi

Have you checked out the output of ipchains or iptables?

# ipchains -L
or
# iptables -L

This is a packet filter.
So if you have working RH7.2, compare the output would be the good idea to find the differences.

good luck
Miguel Covas
Advisor

Re: Remote X App. on RH 7.3

Hi Stuart,

xhosts was a typo.The workstation can be pinged (And since I telneted from it one can suppose that there is bidirectional communication).

appending either :0.0 or :0 to the ip address gives the same result.

Now, I have a new different Linux workstation which can connect with both DISPLAY definitions, so my guess is that there is something different.
dirk dierickx
Honored Contributor
Solution

Re: Remote X App. on RH 7.3

my guess is you have activated the firewall during install.

try this once before you want to start your application:

/etc/init.d/ipchains stop
/etc/init.d/iptables stop

if it works after that, you need to change your firewall settings.

change the type of FW with the 'lokkit' program.

or you can manualy edit the file: /etc/sysconfig/firewall
Miguel Covas
Advisor

Re: Remote X App. on RH 7.3

Hi Dirk, you did it!!

After stopping those services it
started to work.

Stuart Browne
Honored Contributor

Re: Remote X App. on RH 7.3

Miquel, just wondering, is this machine exposed to the internet? Just thinking of the security of your PC.. You did, after all, just disable the firewall..
One long-haired git at your service...
Miguel Covas
Advisor

Re: Remote X App. on RH 7.3

Hi Stuart,

the machine is behind a firewall. I suppose that I could do some fiddling with the local firewall just to find out the proper configuration, but it is just a workstation. We are replacing Linux for Windows and we are somewhat newbies having a Unix machine as workstation (although our servers are Unix machines)
Stuart Browne
Honored Contributor

Re: Remote X App. on RH 7.3

*nod* just thought I'd check.

To make sure it doesn't come up again (as you don't really need it), you can do two things.

one: remove the contents of /etc/sysconfig/iptables

two: chkconfig --level 2345 iptables off

Either of these will stop it from blocking again when you restart.
One long-haired git at your service...