cancel
Showing results for 
Search instead for 
Did you mean: 

Rlogin is not working

SOLVED
Go to solution
jeevanandham
Frequent Advisor

Rlogin is not working

HI anybody ca help me as i am able to telnet & ping the server but rlogin is not working

error - unknown host
i have checked etc/hosts, etc inetd.conf, etc/services everything is fine, but not able to find the exact issue no clear idea about /etc/inetd.sec ?
Thanks in advance
17 REPLIES
Laurent Menase
Honored Contributor

Re: Rlogin is not working

check syslog.log
jeevanandham
Frequent Advisor

Re: Rlogin is not working

you mean /var/adm/syslog/syslog.log ?

what will be the entry ?
rariasn
Honored Contributor
Solution

Re: Rlogin is not working

Hi,

Assigning Points to Replies -- Its a Good Thing!

rgs
Avinash20
Honored Contributor

Re: Rlogin is not working

Please refer to

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=2844
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
jeevanandham
Frequent Advisor

Re: Rlogin is not working

as i a new i do know assinging the point can you tell me i want to assign points to you.. please tell me how to assign rarison i thank a lot to you....
Avinash20
Honored Contributor

Re: Rlogin is not working

Jeevan.. Its good to assign points..unless you find appropriate answers

You could see the tab "Unassigned" for each thread. You could assign point from 1 to 10 where 10 is the highest

No point for this please.
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: Rlogin is not working

Hi Jeevan.

I could find the issue on my server if the host does not resolved.

Chk if /etc/nsswitch.conf file is available.
If not, please copy it

# cp /etc/nsswitch.files /etc/nsswitch.conf

Check now..

If still issue persists

# nslookup
# nslookup

replace IPaddress and hostname appropriately

# rlogin
# rlogin
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Ganesan R
Honored Contributor

Re: Rlogin is not working

Hi Jeeva,

>>>>as i am able to telnet & ping the server but rlogin is not working<<<

How you are pinging and doing telnet? using ip address or hostname?

unknown host generally means the source machine unable to identify the destination by its hostname.

Have you used ip address with rlogin?
Best wishes,

Ganesh.
T G Manikandan
Honored Contributor

Re: Rlogin is not working

Make sure you could ping the server using the hostname rather than the ip, you need to fix the host resolution for this issue, else, rlogin using the ipaddress.
jeevanandham
Frequent Advisor

Re: Rlogin is not working

Hi all my remote server name is spooky

here is how i am trying
root@osshp13:/#ping 135.254.229.180
PING 135.254.229.180: 64 byte packets
64 bytes from 135.254.229.180: icmp_seq=0. time=0. ms
64 bytes from 135.254.229.180: icmp_seq=1. time=0. ms
64 bytes from 135.254.229.180: icmp_seq=2. time=0. ms
64 bytes from 135.254.229.180: icmp_seq=3. time=0. ms
â ¥
----135.254.229.180 PING Statistics----
4 packets transmitted, 4 packets received, 0% packet loss
round-trip (ms) min/avg/max = 0/0/0
root@osshp13:/#telnet spooky
spooky: Unknown host
root@osshp13:/#telnet 135.254.229.180
Trying...
Connected to 135.254.229.180.
Escape character is '^]'.
Local flow control on
Telnet TERMINAL-SPEED option ON

HP-UX spooky B.11.11 U 9000/800 (ta)

login:

---------------------
root@osshp13:/#ping spooky
ping: unknown host spooky
root@osshp13:/#

can any body helpme
jeevanandham
Frequent Advisor

Re: Rlogin is not working

i am not able to see the points which i asigned.. is it OK?
T G Manikandan
Honored Contributor

Re: Rlogin is not working

on sshp13 /etc/hosts file make entry

135.254.229.180 spooky


else can you add the entries with DNS so that the entire would be able to access with hostname.
Suraj K Sankari
Honored Contributor

Re: Rlogin is not working

HI,
Check your /etc/hosts file that your server name is exist or not.

and for rlogin check this line is marked by #or not in /etc/inetd.conf
# login stream tcp nowait root /usr/lbin/rlogind rlogind

remove this hash mark and check this also

Should Bastille ensure the telnet service does not run on this system?
to run bastille
To start the gui, run: /opt/sec_mgmt/bastille/bin/bastille
search for this parameter SecureInetd.deactivate_rtools="Y"

make it no "n"

then run inetd -c to restart the net

Suraj
Avinash20
Honored Contributor

Re: Rlogin is not working

Please add the entry as told above

/etc/hosts

135.254.229.180 spooky

This will do wonders..
This is why we told to check with nslookup
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: Rlogin is not working

Also please refer to the following link to assign points

http://forums11.itrc.hp.com/service/forums/helptips.do?#33

This is a way of saying Thanks to the right answers

Please no points for this
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Ganesan R
Honored Contributor

Re: Rlogin is not working

Hi Jeeva,

Naming resolution, you can do many ways.

If you have DNS server in your environment and the server(osshp13) is configured as DNS client it can resolve the hostname. The entry should have been added in DNS server and your /etc/nsswitch.conf should point to DNS for naming resolution.

See the content of /etc/resolv.conf to know the DNS server details.

/etc/hosts is the local source to put the entries for naming resolution. If you have only limited servers then you can use /etc/hosts for naming resolution.
Best wishes,

Ganesh.
vijay alur
Advisor

Re: Rlogin is not working

Hey Jeevan,

if you tried all of the above solutions and if still you are not able to rlogin then try the following, hopefully it vl help if u have missed these steps


Enable rlogin between 2 or more servers


suppose there are 2 servers (server A and server B)

to allow rlogin between these servers we need to do the following things

1. login to serverA as root.
2. make entry in /etc/hosts for the remote host i.e. serverB.
3. E.g. serverB 192.168.1.2 # the IP address 192.168.1.2 is of the serverB.
4. create a file /etc/hosts.equiv and make an entry in it for host i.e. serverB followed by the user. for the user from the host serverB who is allowed remote login access to the serverA.
5. E.g. serverB vijay #user vijay from the serverB has remote login access to the local server serverA.


OR

1. login as root to serverB.
2. goto the user's home directory to whom rlogin access has to be given.
3. create a file $HOME/.rhosts
4. make the entry of the host name in this file i.e. the hostname whose access is to be allowed for the user. i.e. serverA