cancel
Showing results for 
Search instead for 
Did you mean: 

Rlogin issue

cdslmum
Advisor

Rlogin issue

Dear All,
I have 2 servers A and B,
I want to rlogin without passwd from B to A both are BL860c Itanium servers.
I have created .rhosts file and I have made correct entry also like this I am able to rlogin without passwd by root login from B to A.
but when I am trying to rlogin by a simple user its asking password.
Please suggest me for same.rhosts entry is as following-

B root
B ram

Rgds
Shiv
------------------------------------------------------------------------------------------
This thread has been moved from Storage>tape drives and libraries to HP-UX> general -Forum Moderator
7 REPLIES
Torsten.
Acclaimed Contributor

Re: Rlogin issue

Do you think you posted in the appropriate subforum???

Storage > tape libraries and drives

Consider to post to hp-ux.



If it works for root, you need to configure for other users the same way.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
SoorajCleris
HPE Pro

Re: Rlogin issue

Hi ,

you need to keep .rhosts file in home direcotory of user with entry ,

Regards,
Sooraj
"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity" - Dennis Ritchie
Steven Schweda
Honored Contributor

Re: Rlogin issue

> [...] I am able to rlogin [...]

And who, exactly, is "I"?

who am i

> [...] a simple user [...]

What's "a simple user", and how does it
differ from "I"?

> I have created .rhosts file and I have made
> correct entry [...]

Apparently not everything is correct, or this
stuff would be working. So, rather than tell
us that something is correct, perhaps you
should show us what you have. For example,
on each system:

hostname
pwd
who am i
ls -l .rhosts
cat .rhosts

> B root
> B ram

It might be better if you showed actual data
instead of edited data. Also, as usual,
showing actual commands with their actual
results can be more helpful than vague
descriptions and interpretations.
Elmar P. Kolkman
Honored Contributor

Re: Rlogin issue

If you want the user root to be able to rlogin from A to B without a password, and want user ram on B to rlogin to root on A without a password, this should be correct. But then you need to use the command:

ram@B$ rlogin -l root A
(first part, ram@B$, is the prompt, of course, not part of the command)

Apart from this not being what you want security wise, it should be possible.

If you want to openup your system, you might also look at the /etc/hosts.equiv file and its possibilities (man hosts.equiv)
Every problem has at least one solution. Only some solutions are harder to find.
Deeos
Regular Advisor

Re: Rlogin issue

Hi,


your .rhosts file entry should be like this!



for example:

server A root
server B root


and your .rhosts file resides in user home directory.


then , you can try to log in through rlogin, you will easy to connect your servers each other.
Deepak
Bill Hassell
Honored Contributor

Re: Rlogin issue

The most common problem with rlogin (remsh and rcp) is hostname and IP validation. The destination server will check the incoming system's IP and hostname with the resolver options available to it. If there is a resolv.conf file, then DNS will be consulted. If there is an nsswitch.conf file, then the rules in that file will be followed. To make sure resolver issues are not the problem, add the IP address into the .rhosts file:

B root
12.34.56.78 root
B ram
12.34.56.78 ram

Finally, rlogin (remsh, rcp) will always fall back to a password if the permissions and ownership are not correct for .rhosts *and the $HOME directory. The $HOME directory must be 755 and .rhosts must be 600 permission.


Bill Hassell, sysadmin
Ishwar_1
Frequent Advisor

Re: Rlogin issue

The $HOME/.rhosts file defines which remote hosts can invoke certain commands on the local host without supplying a password. This file is a hidden file in the local user's home directory and must be owned by the local user. It is recommended that the permissions of the .rhosts file be set to 600 (read and write by the owner only).


Host-Name Field

The .rhosts file supports the following host-name entries:

+
HostName
-HostName
+@NetGroup
-@NetGroup

A + (plus sign) signifies that any host on the network is trusted. The HostName entry is the name of a remote host
and signifies that any user logging in from HostName is trusted. A -HostName entry signifies that the host is not trusted. A +@NetGroup or -@NetGroup entry signifies that all hosts in the netgroup or no hosts in the netgroup, respectively, are trusted.
The @NetGroup parameter is used by Network Information Service (NIS) for grouping. Refer to the NIS netgroup file for more information.

User-Name Field

The .rhosts file supports the following user-name entries:

+
UserName
-UserName
+@NetGroup
-@NetGroup

A + (plus sign) signifies that any user on the network is trusted. The UserName entry is the login name of the
remote user and signifies that the user is trusted. If no user name is specified, the remote user name must match the local user name. A -UserName entry signifies that the user is not trusted. A +@NetGroup or -@NetGroup entry signifies that all users in the netgroup or no users in the netgroup, respectively, are trusted.
The @NetGroup parameter is used by NIS for grouping. Refer to the NIS netgroup file for more information.

Examples
1 To allow remote users to log in to a local-user account, enter:
hamlet dewey
hamlet irving

These entries in the local user's $HOME/.rhosts file allow users dewey and irving at remote host hamlet to log in as the local user on the local host.

2 To prevent any user on a given remote host from logging in to a local-user account, enter:
-hamlet
This entry in the local user's $HOME/.rhosts file prevents any user on remote host hamlet from logging in as a
local user on the local host.

3 To allow all hosts in a netgroup to log in to a local-user account, while restricting specified users, enter:
+@century -joe
+@century -mary
+@century

This entry in the local user's $HOME/.rhosts file allows all hosts in the century netgroup to log in to the local host. However, users joe and mary are not trusted, and therefore are requested to supply a password. The deny, or - (minus sign), statements must precede the accept, or + (plus sign), statements in the list. The @ (at sign) signifies the network is using NIS grouping.