Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

SIGBUS error on import

Tim Medford
Valued Contributor

SIGBUS error on import

Running an L1000 server with HPUX 11i. Four gigs of memory and dual 440mhz CPUs.

We are in the process of converting from Oracle 8.1.7.4 to 9.2.0.4. We occasionally have a problem with the import crashing while it is importing a particularly large stored procedure.

ORA-07445: exception encountered: core dump [qcstda()+236] [SIGBUS] [unknown code] [0x000000000] [] []

I saw some similar messages about SIGBUS errors on this forum and increased maxdsize and maxdsize64 to 2gb each. It worked once, but then an import failed the next day.

Has anyone seen this? Any suggestions?

Thanks
Tim
7 REPLIES
Stephen Andreassend
Regular Advisor

Re: SIGBUS error on import

Have you tried upgrading from 8174 to 9201 first, then applying the patchset? Normally this is the standard upgrade path. Also perhaps try increasing the size of the shared pool if you have large plsql blocks.
Stephen Andreassend
Regular Advisor

Re: SIGBUS error on import

Take your trace file and use it with this tool from Oracle:

http://metalink.oracle.com/metalink/plsql/showdoc?db=Not&id=208922.1
Victor Fridyev
Honored Contributor

Re: SIGBUS error on import

Do you use parameter "commit=y" in the import command ?

Regards
Entities are not to be multiplied beyond necessity - RTFM
Brian Crabtree
Honored Contributor

Re: SIGBUS error on import

Tim,

Does it always fail on a single stored procedure, or does it fail on random large ones?

What buffer parameter are you setting for the import as well?

Does the rest of the database complete successfully before hand (tables/indexes). What about dropping the procedure in 8i, and reloading it in 9i?

Thanks,

Brian
Sanjiv Sharma_1
Honored Contributor

Re: SIGBUS error on import

Hi Tim,

Please check this link:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=242927
Everything is possible
Stephen Andreassend
Regular Advisor

Re: SIGBUS error on import

Try repeating the import, but set the initialization parameter to disable PLSQL compilation when loading.

For example:

sqlplus "/ as sysdba"
alter system set "_plsql_load_without_compile"=true scope=spfile;
startup force;

imp ....

Then afterwards go through the procedures and compile them individually.

Also, you should be on 9205 patchset.
Syed Shaffat Ali
Occasional Advisor

Re: SIGBUS error on import

Hello,

Why dont u go for a physical backup restore and upgrade the database.
Recently we did this for converting for a 9.0.1.4 RAC to 9.2.0.4 RAC.
It surely will be more time saving than an import.

Regards.
Shaffat.