cancel
Showing results for 
Search instead for 
Did you mean: 

SSL with Oracle Applications 11i

SOLVED
Go to solution

SSL with Oracle Applications 11i

Looking for a little help. I get the feeling that I am chasing my tail on this one. I just applied Oracle Maintanace pack 11.5.9 and need to setup SSL running on HP-UX 11.0.

I setup the environment using the Oracle note 123718.1 and get an error:

=> $OPENSSL_TOP/bin/openssl genrsa -des3 -out apache_1024.key 1024
warning, not much extra random data, consider using the -rand option
Generating RSA private key, 1024 bit long modulus
9405:error:24064064:random number generator:SSLEAY_RAND_BYTES:PRNG not seeded:md_rand.c:538:
9405:error:04069003:rsa routines:RSA_generate_key:BN lib:rsa_gen.c:182:
amsys4:appldba:/d07/oracle/dbaora_1159/iAS/Apache/open_ssl/bin

I have tried the -rand and get the same error message.

Based on the notes I have read it looks like I am missing the /dev/random and other files, but they are not part of HP-UX 11.0. I have read that I can install SSH.

Has any one else done this? Will SSH on 11.0 give the files I need? Any pointers?
2 REPLIES
Sridhar Bhaskarla
Honored Contributor
Solution

Re: SSL with Oracle Applications 11i

Hi,

Life would have been nice if it is a 11i system. You have /dev/random and /dev/urandom to generate the seeds.

On 11.0, you can generate the key by using -rand option of openssl. Get few files (like swagent.log etc.,), compress them and put them in /tmp as 1.Z, 2.Z etc.,.

Then use the command

$OPENSSL_TOP/bin/openssl genrsa -rand /tmp/1.Z:/tmp/2.Z:/tmp/3.Z -des3 -out apache_1024.key 1024

It should generate the key. You can specify as many number of files you want with -rand option.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try

Re: SSL with Oracle Applications 11i

Sri,
Thanks, that was it. I had tried the -rand but I had the files list incorrectly.