General
cancel
Showing results for 
Search instead for 
Did you mean: 

SUSE Linux Ent 9 .252 kernel does not support SmartArray 5i drivers?

SOLVED
Go to solution
Eric Meiring
Frequent Advisor

SUSE Linux Ent 9 .252 kernel does not support SmartArray 5i drivers?

Hello again,
As mentioned in a previous thread, I have a Proliant DL360 G3 that I've installed SUSE Linux Ent 9 on recently. This server uses the SmartArray 5i.

I see on HP's support site for this server that there is an array controller driver for this OS, named cpq_cciss-2.6.10-11.sles9.i586.rpm.

Days ago, I went to install this and got a message stating that it failed, and that it is not supported by the .252 kernel which I am running.

Just recently, I wiped out all the hpasm/hprsm/etc packages, and reinstalled hpasm (due to another issue I resolved).

Now, going back to install the array controller driver, it tells me it's already installed!

Any guess as to what might have happened, and what I could do to verify that this driver is indeed installed now?

Thanks!

3 REPLIES
Jun Yu
Frequent Advisor
Solution

Re: SUSE Linux Ent 9 .252 kernel does not support SmartArray 5i drivers?

Hi Eric,

SLES 9 with kernel 252 is up to date and should support your 5i controller very well. There is no need to install additional cciss driver from hp site.(252 is the latest errata kernel of SP3).

The driver hp provides is cpq_cciss-2.6.10-11.sles9.i586.rpm and could support their listed kernel 2.6.5-7.97
2.6.5-7.104
2.6.5-7.108
2.6.5-7.111.5
2.6.5-7.139
2.6.5-7.145
2.6.5-7.147
2.6.5-7.151
2.6.5-7.155.29
2.6.5-7.191 - (x86)

252 has more enhancement and bug fix so you can leave this drive alone.

Suppose you did install HP Proliant Support Pack that contains hpasm/hprsm/etc, ofcoz the driver you mentioned above is also included in this pack and will be installed into to the Linux with supported kernel.

you can check your cciss information by invoke rpm -qa|grep cciss or go to /proc/scsi/cciss/X and lspci for further verification.

JOe Yu

just for fun
Eric Meiring
Frequent Advisor

Re: SUSE Linux Ent 9 .252 kernel does not support SmartArray 5i drivers?

Thank you sir!

I think what might have happened is that something was in a muddled or not-quite-right state when it said .252 did not support it. (Or so I thought).

Now I do indeed see that the version I want is on there by using the rpm command you provided.

Knowing that this driver is updated anyway via the kernel update helps me understand.

Thanks!
Eric Meiring
Frequent Advisor

Re: SUSE Linux Ent 9 .252 kernel does not support SmartArray 5i drivers?

Closing the thread since I have found the answer I seek.