cancel
Showing results for 
Search instead for 
Did you mean: 

Samba configuration error

Samba configuration error

I recently install Red Hat 7.1 along with Samba. WHenever I choose the Samba Configuration option I keep geting an error message in Netscape

Netscape connection refused by server 127.0.0.1:901

This happens even if I try to start the process right after boot up. Can somebody tell me what I am doing or did wrong.

Thanks

Trent
3 REPLIES
Albert E. Whale, CISSP
Honored Contributor

Re: Samba configuration error

Trent,

Try and restart Swat (e.g. /etc/rc.d/init.d/swat restart).

If that still does not work then try using the https://127.0.0.1:901

One of these should work!
Sr. Systems Consultant @ ABS Computer Technology, Inc. http://www.abs-comptech.com/aewhale.html & http://www.ancegroup.com
linuxfan
Honored Contributor

Re: Samba configuration error

Hi Trent,

First of all make sure /etc/services has an entry for swat

swat 901/tcp

Secondly you have to create a file called swat in /etc/xinetd.d directory

The contents of the file should be

/Begin/

# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat to configure your Samba server. To use SWAT, connect to port 901 with your
favorite web browser.
service swat
{
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = smbuser
server = /usr/sbin/swat
log_on_failure += USERID
disable = no
}
/End/

This will let you connect only from the machine where the samba server is running, if you want to be able to run this remotely, then remove the line "only_from".

Once you create this file in /etc/xinetd.d, all you need to do is bounce your xinetd (/etc/init.d/xinetd restart)
Now you should be able to run swat from your browser.

-HTH
I am RU
They think they know but don't. At least I know I don't know - Socrates
linuxfan
Honored Contributor

Re: Samba configuration error

Hi Trent,

First of all make sure /etc/services has an entry for swat

swat 901/tcp

Secondly you have to create a file called swat in /etc/xinetd.d directory

The contents of the file should be

/Begin/

# default: off
# description: SWAT is the Samba Web Admin Tool.
# Use swat to configure your Samba server.

service swat
{
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = smbuser
server = /usr/sbin/swat
log_on_failure += USERID
disable = no
}
/End/

This will let you connect only from the machine where the samba server is running, if you want to be able to run this remotely, then remove the line "only_from".

Once you create this file in /etc/xinetd.d, all you need to do is bounce your xinetd (/etc/init.d/xinetd restart)
Now you should be able to run swat from your browser.

==========
Sorry for the repost, but the comments were not correctly placed.

-HTH
I am RU
They think they know but don't. At least I know I don't know - Socrates